Hello everyone,

I am gradually getting to grips with PCSX2. I never thought it possible that the PS2 would be emulated so soon, and have been shocked by the advances which this incredible emulator has made recently.

I bought the PAL version of GT4 a few weeks ago, specifically for the emulator really, although I do have a slim PS2 as well. I cannot get it past the initial splash screen of the game however. When the video starts, it freezes. Now, I have tried enabling the patches in v0.9.6, but this hasn't worked, and I have tried v0.9.7 and this hasn't worked either. If I'm right, v0.9.7 doesn't have patches - they are 'unimplemented'. I even tried making an ISO of the disc using imgburn, but that doesn't work.

I would be grateful if someone could give me a tip or two, as the internet is swarming with fantastic videos of people claiming to have the PAL version working, but the patches in v0.9.6 don't work for me.

Thank you,


Sponsored links

First, use 0.9.7 it has tons of bugs fixed. Also use the image you created, it should be a DVD9 game so make sure it's a proper image, then use the internal iso reader of 0.9.7 to load it (do NOT mount it in any external program)
You can also try pressing start on the black screen, in some builds i recall PCSX2 was just not rendering the video, and people thought it was frozen/not working
[Image: newsig.jpg]
Thank you for your reply Bositman.

I'm afraid I did what you suggested already; I created an ISO file (using ImgBurn) and used the internal reader of PCSX2 to load it. I have also tried pressing many combinations of buttons (all allocated correctly) after the screen goes black, but doesn't work.
Does anyone have any suggestions?
From what I read, sounds like a disc issue. Care to test if it works with your PS2?
[Image: newsig.jpg]
Thanks again Bositman.

Unfortunately, or rather I should say fortuntely the disc works a treat with my slim PS2. I'm afraid that isn't the issue.
Hmm...ok let's start from scratch. Delete all ini files in your /inis/ folder (make sure it's not stored in your user folder of windows, then you have to delete those) and reconfigure PCSX2. Select GSdx as GS plugin, SPU2-X as SPU2 plugin and all other options default. Run the ISO image with the internal ISO loader, make sure "enable patches" and "enable cheats" are unchecked.
[Image: newsig.jpg]
Thank you very much Bositman.

I'm afraid doing what you suggested didn't work, but have since discovered that you were right in some form or another when you said that it may be the disc - perhaps it was the way I ripped it. I tried a downloaded version of the game which worked fine (I bought the original so I don't feel guilty), so I know it must be my rip. I will try with Nero or something. Having said that, it was so slow it was unplayable, but I don't mind that because I know I will have a computer powerful enough one day.

Thanks again for all your help.
It's not about feeling guilty or not... it's illegal either way...

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64

Users browsing this thread: 1 Guest(s)