Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GT4 weird raster/artifacting with progressive scan
#1
I can't really describe what I mean so here's a picture: https://i.imgur.com/svHgHdh.png

There are tiny little rectangles like in a raster pattern when I use 480p mode. Switching between HW and SW mode or between D11 or OGL doesn't help. I've played around with some HW hacks too and haven't found anything. The screenshot is with OGL HW and with Blending Accuracy set to Ultra. I can't find anyone online having this issue. Am I bad at searching, is this issue already known? Is there something else I could try changing and haven't thought of?

Interlaced mode does not have this raster pattern for some reason. But obviously I'd rather use progressive scan if it works properly.

Edit: This also happens in 1080i mode.
Reply

Sponsored links

#2
I'm noticing this issue with other games too, for example Midnight Club 3. Meanwhile PCSX 1.5.0 seems to not have this problem? (Albeit it introduces various other bugs and performance issues) Here is an example in 1.5.0 with OGL HW and Ultra Blending: https://i.imgur.com/D0puTt7.png

For reference the build I've been using is v1.7.0-dev-192-ga06ed3915 (downloaded about a week or two ago so pretty recent).
Reply
#3
I tested 1.6.0 with Midnight Club 3 and the weird effect happens in software mode but not in either hardware modes. I suspect there might have been a change in 1.7.0 builds where hardware mode started being affected by this problem and maybe I'll eventually look for the last working build, or keep checking the recent build for changes. For now this is solved for me though. Seems to be a weird dev build bug. 

For reference: i7 4790k, GTX 970, Windows 10
Reply
#4
Okay, so it's not just me. I did open up a thread about this, but it seems it's affecting more games than just MC3. It does happen on the latest 1.7.0 build as of me typing this, but doesn't happen on 1.6.0. But 1.6.0 doesn't have the graphical fixes for MC3 that correct the missing keyboard keys and the glitchy headlights. I didn't even think of trying software mode - it happens there too as you said. As I mentioned in my thread, OpenGL hardware mode makes this significantly worse, turning it into a checkerboard pattern.
Reply
#5
https://youtu.be/pgPDGIOJZd4
[Image: HkgHT5k.gif]
もっとちゃんと言ってよ
忘れないようメモにしてよ



Reply
#6
I don't think that's what this is, it only looks similar.
Reply
#7
Press Page Down, if it goes away, that's exactly what it is.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
(09-06-2020, 09:09 PM)refraction Wrote: Press Page Down, if it goes away, that's exactly what it is.

Yeah that fixes the problem, thanks.

Which also kind of begs the question though, why is there no option in the UI for changing dithering modes? Hotkeys is the last place I would have thought to look. Kind of unintuitive.
Reply
#9
Because dithering is accurate emulation, the game actually does that. If you want to turn it off permanently you can edit the gsdx.ini and set I think it's ps_dither = 0
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
Yep, that fixes it. It's called dithering_ps2 by the way.
Reply




Users browsing this thread: 1 Guest(s)