GTA Liberty City Stories can't get full speed
Hello. Just registered here looking for help. I know that there is some threads on this subject on this forum, but none of them helped me. I can't configure pcsx2 to run GTA LCS on full speed. Everything I tried didn't gave me any good results.

As mentioned everywhere "allow 8-bit textures" really improves speed, but the game still doesn't run at constant fps numbers , it drops often.

I don't know for sure (CPU is my main concern here), but my system must be good enough to run this thing. My specs are as follows:

-asus p6t motherboard
-intel core i7 950 cpu
-asus geforce gtx 1080 strix graphics card
-12gb ram at 1600mhz

I also tried to use this video to try and config the emu
in this video he sets "allow 8-bit textures" and applies some speedhacks. Game runs smoothly on his system in 1080p with 4x native resolution. Looking on his specs, he got better CPU (core i7 3770k) but my gpu is much better (he uses gtx 960).

I tried to use latest stable version of pcsx2 from download page (1.4.0) and developer version 1.5.0 1648.

Please help.

Sponsored links

That's because he has a better cpu. The single threaded performance difference between the two is huge. Not to mention if he had it overclocked.

Do you have mtvu enabled?
You can also enable a Hw Hack which is "Fast Texture Invalidation" and see if that can give you a slight jump.
CPU: I7-4770 3.9GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ CL9
OS: Windows 10 Pro 64bit
If you can (which you should be able to do) try overclocking your CPU, if it's anything like the i7 920 you should be able to hit around 3.4-3.8Ghz which should give you a pretty playable experience.

Doing what lightningterror suggested should help a fair bit too.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!

Users browsing this thread: 1 Guest(s)