Game Pad Help
I'm using PCSX2 on Ubuntu 12.10 32bit OS and I want to be able to play using my wired xbox 360 controller. However when I configure my buttons using the onepad plugin that came with the linix version I can't use my dpad and analog sticks at the same time, which I need for playing games like kingdom hearts which I really want to play. Is this a problem with the calibration of my controller or do I need a different pad plugin. I tried the Ubuntu version of the pokopom pad plugin and when I try to configure I don't get a screen and it slows down the game screen a lot. I found another plugin, which might work called padwin, which can be downloaded here


Unfortunately I have no idea how to get it to work. By the way I'm rather new to the Ubuntu/Linux OS. It seems I might have to go back to my original Windows 7 OS but I really don't want to do that.

Sponsored links

Please post a screenshot of your onepad page. I used to use the Xbox 360 controller before purchasing a usb adapter for my ps2 controller. I have not had a problem with either. Also, what version of pcsx2 are you using?
attached is a picture of my configurations in onepad. and I have version 1.0.0 (svn)

Attached Files Thumbnail(s)
Attached is my screenshot. I am not sure if your issue is related to drivers as my pad ID at the top looks different.

There is one other option called xpad where essentially you can configure your controller to do anything, even act as a mouse.
Just type sudo apt-get install xpad if you want to try it out.

Ultimately I recommend going on ebay and getting one of those usb adapters for your ps2 controller as it makes life so much easier using your native ps2 controller.

Attached Files Thumbnail(s)
I guess I have no choice but to go find another gaming controller for my computer or go back to my original Windows 7 OS. Other then getting a usb adaptor for my PS2 controller what gaming pad would you recomend.
My MadCatz 360 controller works fine. But the best is the usb. Ebay has the adapters for just a under $10.
how did you get your mad catz controller to work what Linux distro are you using and what version.
I'm currently using Mint 13 (based on Ubuntu 12.04). I have also used Quantal. Heck, this controller has worked ever since kernel 2.6 a couple years ago. To get it to work I just plugged it in. The green light in the center works right away as the drivers automatically installed.
Perhaps the latest version of mint will work. I'll download it and see.
just remember that it should be plug and play. no aftermarket driver needed. i am surprised your screenshot was different from mine, unless you are using a much different brand of controller. just a little bit before .9.8 version i remember not being able to move my ffx character but that was fixed a long time ago.

Users browsing this thread: 1 Guest(s)