Game pad not working in FFXII International. Pleas Help.

I am having problem using my Game pad to play FFXII International Zodiac job. It was working fine till i progressed just a little in the game. Then I couldn't move left to right then up or down and then it went mad. Nothing was working I am using LilyPad 0.11.0.

My setting only changed for the Gamepade controller setting. However other games run fine!!
My game pad is called DILONG (USB NETWORK JOYSTICK).

I have noticed that when I try to bind it is overlapping. So when i assign left using directional buttons it works but then when assigning the left to the analogue stick it takes over the directional button. Crazy isn't it? And if i am assigning the pad buttons they don't work either.

My PCSX2 is 1.2.1.

May I also add that it says the joy pad is working fine but i cant find it in the Device manager!! I have also made sure that it is installed and updated.

Any advise on setting or something that i can do?

Many thanks.

Sponsored links

Do you have an analog button? If yes, what happens if you press it and map again?

Please check functionality in windows system settings -> joystick and game controllers or something like that.
I have two analog sticks and they do nothing sometimes and sometimes they do different things. But when i try to bind them they start to overlap with the pad directional buttons. Also in my game pad there are 4 buttons (starting from 1-4) replacing the square and other ones but when trying to assign them it starts from 0 and not 1!!

That's what you said in your first post.

I wanted to know if you have a button probably centered in your controller that is named 'analog':
[Image: 16397d1360523165t-generic-usb-joypad-rig...tons-3.jpg]

And please check functionality by means of windows game controller interfaces.
Yes there is a button in the center called Analog.

The pad is actually similar to this one and has the same key pad numbered buttons 1-4 with two sticks and 4 front (L+R) buttons.

Do you mean by check functionality is to try using the joypad with a pc game that is not the emulator?
then push the button.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Windows game controller interface:

[Windows-START] -> 'setting up USB game controller' (or something similar - just type in 'USB')

Looks like this:
[Image: k7oEf.jpg]
My friend nothing changes!! Still the same problems.

It seems to be an overlap when binding the X and Y for sticks with the pad directional buttons. So that they take over each other sort of thing. I dont know if that makes sense!!

Yes I checked that it is working Ok and the latest driver is installed.
(07-09-2015, 07:36 PM)nazoom Wrote: Yes I checked that it is working Ok and the latest driver is installed.

How could it be working ok if:

(07-09-2015, 07:36 PM)nazoom Wrote: It seems to be an overlap when binding the X and Y for sticks with the pad directional buttons.

This doesn't sound like working ok.

Please go into windows gamepad settings and check functionality of all buttons. Especially if they are overtaking other buttons or not.

Thanks for the advice. I am now having problem even when binding. Nothing seems to be working now!!

The status of the Game pad it says OK. I even tried to calibrate and now it is not responding!!

Do you think i should try a different or new Game pad? What do you recommend?


Users browsing this thread: 1 Guest(s)