Game plays w/ random black screen
Hello! First off, thanks for making this great program for us to use!

Well let's describe the issue. I searched alot about black screen issues, including here on the forum too. No one had this specific problem I saw.
I adjusted some configurations and got the games to play from iso files. Things play pretty smoothly (with some timing or sound issues, but otherwise superb!)

The only problem is every couple of minutes or so at random the screen will go black, I can still hear the sound. If I take it out of full screen, I can see the last frame of video where it froze up. I can still hear the sound playing and even the noise of me making moves with the controller. The only thing I could do was do a save state, close the game, then load the save and that seems to refresh it and I can continue on again (until it randomly goes black again of course).

I've been trying to tweek every thing I can think of to try to alleviate this problem. If there is any advice at all, that'd be great.

My specs:
vaio laptop running Windows 8
Intel i5 @ 1.8ghz, 4 core
graphics card also from intel HD 4000 series it says. (Not sure, but it says it supports DirectX11)
I'm running pcsx 1.0.0, latest ver.
I only tried two games so far, but both had the same problem. (FFX and Dokapon Kingdom) playing from iso file.

Thanks again!

Sponsored links

Ok,First Dokapon Kingdom its out the compatibility list of here and i dont know nothing about(maybe is not a playable game yet,not work good),second i m afraid of you notebook maybe dont have resorces enogh for play the demanding Final Fantasy X,try in native resolution,maybe you are tryn in very high resolutions above the cappacitie of your notebook,(unfortunately notebooks in general are weaks for this emulator),and you can test both Hardware mode and Software mode to look,anyway its better you use not Pcsx2 1.0 but 1.1 lasts versions-Here the link,download the last,please
After this,check theses games again,even after all this the problems persist,report here again.
If you post the emulog maybe we can help you!
Core i3 9100f 3.6Ghz
nvidia GT 1030
pcsx2 version-1.3.1  
Hello, thanks for your fast reply!

I know Dokapon Kingdom is not in the compatibility list, but I tried it anyway (it actually runs pretty perfect besides the same prob as with FFX). I already dropped the resolution down to native, that seemed to fix alot of the off frame rate, but still get the random black screen. I will try changing software mode to hardware mode too.

I didn't DL 1.1 because it said that it might gonna be unstable ver. So I dl-ed the last most stable ver. from their dl page. Is that right?

And here is the emulog right after I was playing through a bit of FFX and got a black screen pop up.

PCSX2 1.0.0.r5350  - compiled on Aug  1 2012
Savestate version: 0x9a080000

Host Machine Init:
    Operating System =  Microsoft  (build 9200), 64-bit
    Physical RAM     =  3975 MB
    CPU name         =  Intel(R) Core(TM) i5-3337U CPU @ 1.80GHz
    Vendor/Model     =  GenuineIntel (stepping 09)
    CPU speed        =  1.795 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7fbae3bf
    x86EFlags        =  28100000

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\gsdx32-sse2-r5350.dll
Windows 6.2.9200
Intel(R) HD Graphics 4000 (
    Binding  PAD: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\PadSSSPSX.dll
    Binding SPU2: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\spu2-x-r5350.dll
    Binding CDVD: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\cdvdiso-r5350.dll
    Binding  USB: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\USBnull.dll
    Binding   FW: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\FWnull.dll
    Binding DEV9: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9640 games on record (loaded in 197ms)
    HotSwapping to new ISO src image!
HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
Windows 6.2.9200
Intel(R) HD Graphics 4000 (
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: C:\Users\Renee\Documents\Games\FFX.ISO
    Image type  = DVD
    Fileparts   = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2252816 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0: C:\Users\Renee\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Renee\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v01.60(07/02/2002)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPS_250.88;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLPS_250.88;1) Game CRC = 0x658597E2, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPS_250.88;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(GameDB) Enabled Gamefix: IpuWaitHack
EE/iR5900-32 Recompiler Reset
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPS_250.88;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPS_250.88;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(R5900) Re-executed ELF Entry point (ignored) [addr=0x00100008]
Closing plugins...
    Closing DEV9
    Closing FW
    Closing USB
    Closing CDVD
    Closing SPU2
* SPU2-X: Waiting for DSound thread to finish... Done.
    Closing PAD
    Closing GS
Plugins closed successfully.

I'm running GSdx plugin on SSE2 (I read it's lowest one) I got 3D11 hardware ver. selected w/native resolution.

Other unusual settings, for SPU2-X Interpolation: nearest. Output module: 2 direct sound, syncrhonizing mode: none, audio expansion mode: stereo. I didn't realize it, but I had speed hacks enable, and also one game fix was still enabled (I thought I unchecked that one).
Firstly id update your video card drivers. Google "intel driver update utility" run that and update any which have a new version available
[Image: ref-sig-anim.gif]

Hello! This is a bit delayed.

I tried disabling the speed hacks. Also went to check if my computer had any energy efficiency settings on. I disabled these too.

Tried the games again, and everything is working perfectly now!! (Even Dokapon Kingdom is doing flawless! Maybe add it to compatibility list?)
Thanks alot for your input guys!!

Users browsing this thread: 1 Guest(s)