Game stopping bug / issue with Red Faction 2 on PCSX2.

I am stuck in Red Faction 2 in the Propaganda Center level. I can't progress any further because of an PCSX2 issue. A catwalk is supposed to drop down from the ceiling to the ground so that I can walk up to the 2nd floor and through a door to continue through the level. However, when I reach this catwalk that's supposed to drop down in a slope, using PCSX2, the catwalk just flips vertically at a 90 degree angle to the ground, making it impossible to proceed further.

I am using PCSX2 0.9.8, and Super VU recomplier enabled. That's the only VU option that Red Faction 2 will run on. Interpreter and normal recompiler mode causes the game to lock up. The "game fixes" is un-enabled, meaning automatic fixes. All other PCSX2 settings are default as far as I know, except controller configuration. I simply switched around which keys are mapped to which PS2 buttons.

The game runs fine when set up with Super VU. The FPS and graphics are fine, except for 3-D objects like enemy soldier heads jerking around when I kill them and cutscenes not showing properly. Other games like Red Faction 1, Maximo, Drakan, etc. work just fine so I don't think it's a computer or graphics card issue.

Sponsored links

tried software mode ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
[Image: redfaction2bug1a.png]

The bugged catwalk that prevents me from progressing further.

[Image: redfaction2bug1b.png]

This is what the catwalk is supposed to be doing / located, sloping down like this.
(07-18-2012, 01:52 AM)jesalvein Wrote: tried software mode ?

Direct3D software option in the setting menu? I'm using the GSdx9 plugin.

EDIT: I just tried, and the same problem exists on both hardware and software versions. By the way, the regular recompiler is "MicroVU".
use an SVN version. there are VU fixes that might apply here
I finished playing Timesplitters 2, which ran beautifully on PCSX2. Having beat the game and 100% completion with everything unlocked, I decided to go back to Red Faction 2. I tried the SVN software option in the GSdx9 plugin options, and I still have the same problem. Jerky 3-D graphics and the catwalk standing up as in the picture I posted above.

Are there any other good plugins besides GSdx9? I'm starting to suspect that the only VU that Red Faction 2 works on is the Super VU one, and that one might be causing the jerky 3-D stuff to happen.

Users browsing this thread: 1 Guest(s)