GameDB not found

I'm starting to test the new 0.9.8, and I found a small problem loading the GameDB. I installed the app using the installer. All OK, but it is trying to load GameDB from a old path of PCSX2 installation.
I tried unstalling all, using a reg cleaner, manually clean and delete the config files..... no luck, keeps trying to load the gameDB from a folder that does not even exists.

Where is this config parameter being saved? Can I manually edit it?


Sponsored links

Try using the binary pack, it should work ok then (no uninstaller then but I don't think you need it this much for PCSX2)
[Image: newsig.jpg]
You're looking for the registry path HKEY_CURRENT_USER\Software\PCSX2 and the key that points to the older install folder is Install_Dir (That's on Windows XP SP3, but later OSs should be similar). Modify it to point to the new install folder and you should be good.

There seem to be an issue when installing 0.98 over a not-completely-removed 0.97. The new install silently "imports" the install dir from 0.97 registry, and therefore looks for the games DB file there.

Here's the info I got so far:

I've noticed that 0.97 (r3878) uses registry path HKEY_LOCAL_MACHINE\SOFTWARE\Pcsx2 and I _think_ that's what being "imported" to the 0.98 registry path HKEY_CURRENT_USER\Software\PCSX2 . Note that 0.97 is at HKEY_LOCAL_MACHINE while 0.98 stores its settings at HKEY_CURRENT_USER.

I also noticed that completely removing 0.97 clears the 0.97 registry path (removes it completely), and when the 0.97 registry is clean, removing and reinstalling 0.98 (you can keep the user files - savestates etc), it clears the 0.98 registry entry. Once both the 0.97 and 0.98 registry entries are clean, 0.98 can be reinstalled and everything is OK (and the games db files loads properly from the 0.98 install folder etc).

So, for now, if you encountered this situation:

1. Just in case, backup (=make a copy of) your savestates files, plugins config, etc (typically at \PCSX2 ).
2. If you have 0.97 installed as well, remove it completely (it doesn't delete your ini files, savestates etc). (If you don't have it installed, either install it and remove it completely, or just delete the remains of 0.97 registry path HKEY_LOCAL_MACHINE\SOFTWARE\Pcsx2)
3. Remove 0.98 - select only the first option (keep the plugin config files and user files)
4. Reinstall 0.98, and import the settings as suggested.
5. You should now have a properly installed and configured 0.98 installation, using your original configuration.

Please let us know if this procedure works for you.

Also, worth noting, PCSX2 supports only a single "Install" instance, but as many as you like "Portable" instances which don't interfere with the Installed instance (or with other portable instances). The 7z binary package of 0.98 (4600) is already configured as "Portable", so just extract it to a custom folder of your choice and you're good to go. If you feel adventurous, you can manually convert your Installed instance into a Portable folder by adding an empty file named "portable.ini" at the same folder of pcsx2.exe. This will cause it to ignore the registry entries alltogether, but note that you should do that at a folder to which you have write permissions (specifically, not "program files" of Vista or Windows 7, so it's mostly good for XP users with admin permissions).
I deleted the registry keys, and the GAMEDB loaded perfectly!!! Thanks! With the correct settings.
PCSX2 rewrote the registry the next time I run it.
But I'm going to reinstall 0.9.8, to get a clean install.

You could add to the installer some code to delete the old registry keys. And get rid of this problem.

(05-14-2011, 05:05 PM)DXeros Wrote: I deleted the registry keys, and the GAMEDB loaded perfectly!!! Thanks!

Can you describe the exact procedure please? and also, what registry entries you had already, and whether or not you also had 0.97 installed or only partially removed?

I had PCSX2 0.9.7 installed. Then I installed 0.9.8 (because I thought it was not installed), and the problem came up.
I uninstalled 0.9.7, but it did not fix the problem. I deleted the config files, but also no fix. I tried with lots of things, but I supose the keys are not being deleted easily.

The solution was to enter HKEY_CURRENT_USER\Software\PCSX2 and delete all the keys with PCSX2 Paths inside.
The next run of the PCSX2.exe, rewrote the keys with the correct paths. And thats all, fixed.
The tricky part is not forgetting to reinstall PCSX2 once the register is cleaned from previous installs, even if it is yet installed. The reason is exactly to redo the register entries.

Again, for those yet not aware, avoid installing ANY game on the default C:\Program Files (x86) or C:\Program Files. Yes, this is valid for PC games too.

In time: actually avoid installing in any "specially protected" folder, which includes the Documents (anything under the Users folder) and the Desktop (this last more because of performance, the desktop should never host more than icons and the fewer the better).
Imagination is where we are truly real
shouldn't the gamedb's location be hardcoded relative to the pcsx2 executable?
(05-15-2011, 11:37 PM)Squall Leonhart Wrote: shouldn't the gamedb's location be hardcoded relative to the pcsx2 executable?

Due to the many command line options, the configurability of PCSX2, and portable/install modes, the folders handling is quite complicated.

In normal Install mode, the installation directory is the one at which the games db files is looked for, and that is written at the registry (for install mode), hence the issue when installing 0.98 over 0.97 without properly removing 0.97.

It can be considered a bug, and for now the solution is to either clean the registry manually, or (reinstall and) remove 0.97 and 0.98, then reinstall 0.98, as I noted earlier. If done properly, all user files and configuration should stay intact.

Users browsing this thread: 1 Guest(s)