Gamepad Issues

I have PCSX2 1.4.0 using lilypad 0.11.0 controller plugin on Windows 10

It won't properly recognize my gamepad, which is a wired USB XBoxOne controller: Intel® USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)

Drivers are up to date on the controller (10.0.14393.0)

The Device Diagnostics is recognizing the gamepad as 4 separate gamepads, and won't recognize any input from any of them. I have no idea how to fix this.
It lists my Devices as:

WM Keyboard
XInput Pad 0
XInput Pad 1
XInput Pad 2
XInput Pad 3

When testing the pads, all the inputs are ? and pressing the buttons doesn't register.

I've tried every combination of Input API's and nothing seems to work, and I've tried using Pokopom's Plugin, which doesn't work and doesn't seem to have any configuration options. I've made sure to update the drivers for the controller, restart my computer, plugging in the controller while it's off, starting the emulator while still plugged in, and it still registers as 4 gamepads. 

Any help on the subject would be greatly appreciated.
Thanks in advanced.

I should also add the controller is designed to be used for the XBoxOne, and functions perfectly for every other emulator and PC native game that I have. This is the first time I've run into issues with this controller.

Sponsored links


I figured out what was happening, it was not anything software related, the USB port I was using is malfunctioning. After switching to another USB port everything works perfectly.

Users browsing this thread: 1 Guest(s)