Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gamepad issues, with a bizarre cause.
#1
Right, I had some gamepad issues before that seemed to come and go. After appearing to vanish, I gave it not a second thought. Recently, this resurfaced, and I was actually able to pin down part of what's causing it to happen, but no idea why, or how to fix it.

When I boot pcsx2, everything works, no problems. Except sometimes it refuses to read my gamepad. 'test' for that controller shows every option as ?.

Here's the weird part. This ONLY happens if I run pcsx2 after running DeSmuME.



...Yeah. I have no idea why, but if I run desmume, pcsx2 won't read my gamepad correctly again until I reboot the entire computer.

Does anyone have any idea how to resolve this problem? And is the problem being caused by pcsx2, or by desmume? Constant reboots aren't exactly much of a solution.

Windows 7 OS, pcsx2 1.2.1 r5875, DeSmuME 0.9.11 x64. Gamepads a ps3 rock candy, though the problem exists with other gamepads as well.
Reply

Sponsored links

#2
I'm guessing it has something to do with the way DeSmuME hooks the controller.

Let me see if I can reproduce this issue.

Could not reproduce with DeSmuMe 0.9.12 x64 SVN and PCSX2 1.4.0

Speaking of that 1.2.1 is outdated and unsupported, please update to 1.4.0
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
Yeah, noticed that a bit after I posted. Updating, hoping that will solve the problems.
Reply
#4
Hmmm. I don't see desmume 0.9.12 on their website. Last news post was about 0.9.11 reeasing in april 2015, downloads section doesn't have an 0.9.12. Ditto the sourceforge page. New PCSX2 version doesn't change the existing problem. Where'd you find desmume 0.9.12?

Update. Buildbot of the most recent desmume (build 5370) with pcsx2 1.4.0 generates the exact same problem. PCSX2 just reports my gamepad as ? for all inputs if desmume's most recent build was run before.
Reply
#5
Hello. So pcsx2 1.4.0 was working wonders. I bought a new gaming PC and i wanted to install it, i did, again all wonders but i have the exact same issue you have, my logitech rumblepad 2 appears with ? ? ? when i test the device, so i cannot configure it to play PS2 games, any ideas?
Reply
#6
Ask Logitech for updated drivers.
And next time, please open your own thread
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)