Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gamepad moving system cursor
#1
Folks,

I am on a Dual Monitor Win 10 system, with a Logitech F310 Gamepad. I configured PCSX2 to XInput and defaults.

When running a game in PCSX2 (in Full Screen on monitor 1), the keypad inputs seem to make it into the game OK. But they are also driving the Windows cursor, so as I move around the cursor drifts outside the game. Then when I hit the X or Circle buttons, they pass through to where the cursor is as left and right mouse buttons.

Is PCSX2 supposed to capture those, or is there a system setting I am missing to divorce the gamepad from the mouse ?

Thanks,
Dale Pennington
Reply

Sponsored links

#2
Your gamepad is likely set to register with Windows as a mouse device. You will need to refer to the manual for the device as to figure out how to stop that. That is not something PCSX2 itself will have any bearing on.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#3
Researched the Logitech web site, it was not much direct help. But noticed by pad was an XInput device, so I disabled DirectInput in the pad configuration, and it now appears to work OK. Still have a request in to Logitech, as their Gaming support software does not even recognize the pad.
Reply
#4
Not a fix after all. Seemed to work one time, then back to moving the mouse cursor. Still investigating
Reply
#5
At first pass that does appear to have fixed the issue. My guess is Win10 is automatically passing XInput to OS as well as app. While DirectX does not.

I will be giving it a bit more of a workout to be sure though
Reply




Users browsing this thread: 1 Guest(s)