Gamepad not responsive in pcsx2?
Gamepad responds fine in all other programs, in lilypad it's listed among the various devices it detects, but when I attempt to define inputs, the program doesn't register any input off any button on the gamepad.
Same results in the other plugins.
Google-fu failed me, finding nothing beyond configurations not saving, or tools to use wireless ps3 controllers (which this isn't anyway) with a dongle.

Anyone who can help me figure out what's keeping PCSX2 from recognizing my gamepad, I would be quite thankful.

Sponsored links

tried raw input instead of windows messaging ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Hit raw input on the upper left window, hit apply, went to the pad 1 tab, no response from the gamepad from any button or stick.
Please check response in the first tabpage of lilypad where the input devices are listed -> Test Device. Are all buttons working?
Please screenshot the same (first) lilypad tabpage.
Uhhmm.... as embarrassing as this is, the problem appear to have vanished. Booted pcsx2 to do as you asked, and test device actually read input this time. Previously, it simply listed a whole bunch of ??? data for various inputs when I test the gamepad, and none of them changed when anything was pushed. it appears to read and register just fine now.

I'm now even more baffled then before, but at least it works now...

As for settings on the first page, they're identical to default, though that's not relevant now...
I was expecting something like question marks if the input doesn't work but is still registered. Otherwise it probably would've told us what kind of input it is.
Glad that it worked out. Sometimes restart is the best medicine for pc's.

Booted pcsx2 up again today, got the exact same bug again. My controls are still set up, but the gamepad doesn't respond, and upon testing shows ? for all options.

Can you please screenshot test device screen and second tabpage of lilypad settings?
....Alright, this is even more infuriating. Gamepad responds now, for the moment, but sicne I'm sure it'll bork again later, here's the second page of lilypad settings.


And here's the test screen. It looks identical, except I get various 1's and 0's now, instead of everything on the right column being labeled with '?'.


I don't understand why this is working only intermittently. Help?
I would say possible HW issue (broken cable, broken chips), possible power saving issue (USB goes to sleep but doesn't come back appropriately) or possible service/windows sleep/hibernate issue where a service or the driver is not correctly restored. But just guessing here.

Users browsing this thread: 1 Guest(s)