Gamepad with 'Round' Range of Motion Doesn't Work Right in QT
I have a one month old "Logitech F310" gamepad.  It works fine with Windows games, Dosbox, Dolphin, etc.  The default (or when calibrating) in Windows it has a Round range of motion rather than Square like my old gamepads (see the red circle in the screenshot).  Seems to be how these gamepads are made.

In PCSX2 3d games, if I hold the analog stick forward so my character is walking forward, then move it to the upper-right my character STOPS completely!  Same with the bottom-right etc. (Of course the right analog stick has the same problem.)

This happens with QT 1.7.3269 and some older ones, but NOT with WX 1.7.3269.

There is a closed issue #6230 that says this is a Sensitivity issue.  With this gamepad it is NOT.  Sensitivity for me just does what it is supposed to do, I tried Sensitivity up to 2.0 but it is just more sensitive & moving the stick to the 4 corners still acts more like the stick is centered (since my characters in games stop moving)!

So far I've tried "Call of Duty Finest Hour", "Destroy All Humans", "Medal of Honor Vanguard" & "The Simpsons: Hit & Run".

EDIT: Since version 1.7.3433 this is FIXED for me!! (Probably fixed in 1.7.3431 with the "Add DInput input source"??)
The new DInput mode works for this controller also.
I should have said above; this controller has a switch for "XInput" & "DInput" modes, which BOTH work now.

Thank you... Very nice to finally be using QT!

Attached Files Thumbnail(s)

Sponsored links

Users browsing this thread: 1 Guest(s)