Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gameplay stuttering while showing 60fps HELP!
#1
Hello again, I'm posting new thread about some bug that a few people are experiencing (including myself).
The problem is present in Windows 7, don't know about other systems thou.
I have aero enabled which gives me vsync all the time, also in pcsx2, I get no screen tearing without enabling vsync opton in emu settings which is nice boost to speed BUT now for the problem.

All tested games are running in 59-60fps all the time, Scaling 3x, texture filtering full, DX11 (usually, sometimes DX9 gives less glitches), wildarms offset hw hack and 8bit filterng sometimes.
Nevertheless my games (every single one) is having video stuttering -plays smooth and after few seconds going like frameskip or lower fps for about 2-3 seconds, then fluid again, no sound distortion at all, fps still showing as 60, only recommended speed hacks used.

I figured that this problem can be eliminated by turning on v sync option in pcsx2, don't have a clue why?? but anyway, sadly this gives REAL fps drops in some games (slower game, sound stutter, 45-50 fps shown).

I actually tried to use some program called D3DOverrider, enabling vsync and triple buffering by this - some guy on the forum listed this as best solution for my problem, then again same fps drops like while vsync enabled thru pcsx2 Sad

Turning on high performance doesn't give any boost, and even when I get those REAL fps drops due to the vsync applied, EE is going to 70-80% max and GS 20-30%, my processor usage is about 60%...

Like I said in other post, I tried so far:

Tried enabling vsync and triple buffering via nvidia control panel (pcsx2 vsync off) to remove stuttering but this didn't work that way - gave me no tearing but standard stutter.

Tried disabling aero and disabling vsync in pcsx2 - had tearing AND stuttering, worst scenario.

Tried enabling vsync in pcsx2 with windows aero on, had perfect screen without tearing and stuttering BUT slow performance.

Tried using D3DOverrider with vsync and triple buffering ON, aero on, vsync in pcsx2 off, same as above - would LOVE to finally achieve no stuttering and no tearing and also normal speed like when disabled v sync I know this just MUST be achievable some way.
Maybe some build had this problem eliminated?

Please help, I will be having about 2 weeks free of work due to christmas eve and would strongly want to beat again Okami, DQVIII, Onimusha 2, Devil Summoner, Haunting Ground and Namco x Capcom in upscaled graphics... big screen... Oh Okami looks just GORGEOUS \*o*/ best christmas wish would be solving this problem.

MY SPECS:
PENTIUM G3420 @ 3.2GHZ
GEFORCE GTX 750 1GB GDDR5
1X 4GB RAM DDR3 1600MHZ
ASROCK H81M ITX
FORTRON 460W
WINDOWS 7 SP1 X64
Reply

Sponsored links

#2
You harddrive may be bottlenecked. Try running the game from a non system drive, usb stick ect. Mine would stutter/freeze frame drop to 47fps then return. Windows was beating up my hardrive for whatever reason. Put my isos on secondary drive. Runs smooth as butter. O also vu stealing can cause screen flicker.
Reply
#3
I have system on C: and PCSX2 as well as ISOs on D: another thing that can make me think that's not harddrive is vsync enabling would solve this problem, that's pretty weird...
Right now using PCSX2 v1.2.1 r5875, tried newest one from buildbot, no difference at all.

Looking at some changes in development right now and saw this:

Code cleanup:
Removed managed Vsync

Hmm is this could be related to solving my issue?
Other people also had this, so maybe new stable build will stop this stuttering...
Reply
#4
Are you using ee or vu stealing? Try turning all speed hacks off
Reply
#5
No, like I stated in first post, only recommended speed hacks, even without any speed hacks I get this slight stuttering.
I wonder how much enabling vsync would actually drop fps, 10-20?
And enabling this is using only GPU/CPU or both?

Tested so far, in native 3x, aero win7, vsync ON:
-Okami (DX11) 60 fps smooth, dx9 had some drops to ~50fps
-Devil Summoner vs Soulless Army (DX9, due to better compatibility) 60 fps smooth.
-RE Code Veronica X (DX9, as above) 60 fps smooth.
-Castlevania LoI (DX11) 60 fps, tested just few minutes.
-Onimusha 2 (DX11) 60 fps.
-Dragon Quest VIII (DX11) constant drops to even 40-45fps, and about 50fps in native 2x. Is that because 3x native and vsync are too much to GPU?
-Haunting Ground (DX11) 60 fps, EXCEPT while looking into the mirrors, then drops to 50-55, just alright playable.

Tested these games only few minutes but they work flawless with vsync, only DQ gives me dropped fps, and for this game I'm turning off v sync and play with this micro stuttering, isn't so bad because it's just rpg xP.
Reply
#6
Well sounds like most games working good. Pcsx2 emulation is not a perfect science. Some games just don't emulate well. An occasional frame rate drop bound to happen here and there.
Reply
#7
Markyrocks69, yes I know that there are speed issues here and there but most people don't have issue like this, also why is that vsync must be enabled to game work smooth while 60fps? I understand common fps drops, like when enabled vsync (shows 50 fps and analogically game runs slower, choppy sound, normal thing) but I just don't get choppy animation while running constant 60fps but WITHOUT vsync...

This option is supposed to counteract tearing, not smoothness.
Reply
#8
Do you have this issue when you use the native resolution? By the way, Dragon Quest VIII is very GPU demanding.
Reply
#9
Yes, it is the same in native, so I assume this has nothing to do with performance issues.
Some of You guys recommend setting pc in high performance power mode but this didn't seem to have any advantage over balanced plan in running pcsx2, got exact same performance and stuttering without vsync and fps drops in DQVIII while vsync enabled.

BTW, another person who had this issue, maybe it could set us in direction where to look for solution to NOT HAVE vsync enabled in pcsx2 and get smooth display with no tearing.
http://forums.pcsx2.net/Thread-60-fps-bu...-30?page=2
Reply
#10
Only other thing I can add is certain speed hacks can cause the fps counter to give false readings. It's possible that your cpu is not fast enough to push ultra demanding games. Try overclocking. That cpu supposed to oc to over 4 ghz with ease.
I guess the way to test that is to run the game in software mode. See if it does same thing.
Reply




Users browsing this thread: 1 Guest(s)