Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Games running in slow motion
#1
I am trying to play several games on PCSX2 1.4.0 and they run in slow motion. I get 60 fps, but still lag. Why is this, and how can I fix this?
Video:
https://www.youtube.com/watch?v=flKqspw6C9A
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(10-19-2017, 11:09 PM)jesalvein Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.


i7-6700
GTX 1070
8GB ram
Win10
PCSX2 1.4.0
Settings are all default except for speedhacks(Which are on 6)
I am playing Madden 08 and F1 06, both from ISO.


Attached Files
.txt   emuLog.txt (Size: 1,2 KB / Downloads: 28)
Reply
#4
Speedhack level 6 will turn VU cycle stealing up to level 2, which from my experience only causes more harm than good. It seems to sometimes make games run like this, where audio and the emulator's reported framerate are full speed, but under the hood processing is much slower. With your hardware I would think you don't need to run the preset that high. I would try...
  • Turning the Speedhack preset down to 2 (the default)
  • Enabling MTVU (Multi-Threaded microVU1)
If that doesn't do the trick, consider...
  • Unchecking the preset box.
  • Manually adjusting EE cyclerate downwards. If no improvement, then try upwards. If upwards makes it worse, try adding NO MORE than level 1 VU cycle stealing.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
#5
(10-19-2017, 11:30 PM)pandubz Wrote: Speedhack level 6 will turn VU cycle stealing up to level 2, which from my experience only causes more harm than good. It seems to sometimes make games run like this, where audio and the emulator's reported framerate are full speed, but under the hood processing is much slower. With your hardware I would think you don't need to run the preset that high. I would try...
  • Turning the Speedhack preset down to 2 (the default)
  • Enabling MTVU (Multi-Threaded microVU1)
If that doesn't do the trick, consider...
  • Unchecking the preset box.
  • Manually adjusting EE cyclerate downwards. If no improvement, then try upwards. If upwards makes it worse, try adding NO MORE than level 1 VU cycle stealing.

Thanks, changing the speedhacks to 3 worked.
Reply
#6
So you can avoid using speedhacks, you could try the latest development build as when we released 1.4.0 there was a bug with the AVX plugin and Skylake CPU's which caused them to run really slow, but we have since fixed that issue

You can grab the latest development build here:
https://buildbot.orphis.net/pcsx2/index.php
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(10-20-2017, 12:12 AM)refraction Wrote: So you can avoid using speedhacks, you could try the latest development build as when we released 1.4.0 there was a bug with the AVX plugin and Skylake CPU's which caused them to run really slow, but we have since fixed that issue

You can grab the latest development build here:
https://buildbot.orphis.net/pcsx2/index.php
sorry to bump an old thread but  my game runs so slow and i cant fix it. i downloaded what you linked, do you have to uninstall pcsx2 if you already have it and then install what you linked?
Reply




Users browsing this thread: 1 Guest(s)