General GSdx AA hack crashes and very minor sound issue in Xenosaga II
Hello guys. First of all, let me say how amazed I am at the advancements made by PCSX2 and its plugins in the last year: I installed the latest beta after quite a while since the last time I used PCSX2, and I'm finding myself able to play very well a lot of games even with a pretty mediocre machine Smile

I'm however experiencing two issues (well, one really, the other one is just a minor nuisance with a specific game) I'm hoping someone will be able to shed some light on.

My specs:
AMD Athlon II X2 3GHZ (dual core)
ATI Radeon HD5750
Onboard realtek HD audio card
Win XP (and as such DX9)

Issue 1 - When I try enabling the HW antialiasing hack in the GSdx plugin the emulator crashes with an unhandled exception as soon as I start either an iso or just the BIOS, no matter how many levels of AA I try setting and regardless of how everything else is set in the plugin.
As AA in GSdx is an hack you even have to enable in the ini before being able to set it, the "use at your own risk" concept goes without saying, yet I was wondering if there is a way to pinpoint the reason for the crash (and hopefully solve it). Maybe it's a common issue for ATI users, for instance, or some catalyst drivers versions are known to give these troubles... you get the idea. Searched for it, but couldn't end up with any post mentioning a similar issue.

Issue 2 - After having been able (to my surprise after reading so many posts mentioning how it was a resource hog) to play Xenosaga I at very good speed even with stunning X4 resolution (well, at least my GPU is decent Tongue ), I'm now on Episode II. Runs fine, and I'm able to keep steady 60 fps in all battles, with just some seldom slowdown during exploration when there are heavy shaders/particle effects on screen (smoke, explosions).
Anyway, the issue at hand is apparently skipping/microcrackling sounds on certain SPECIFIC attack sounds during battles. This affects especially a couple of chaos' and momo's attacks. While other charas seem unaffected, I was able to reproduce the issue with the very same attack sound (for instance, momo's second to last arrow in a full stock chain of attacks) several times, though it doesn't always happen (and strangely enough, it looks like it tends to happen only when attacking a specific kind of mob: in momo's example, again, I can steadily reproduce it when she attacks the helicopter in the very early stages of the game, but not when she attacks an enemy soldier).

As they don't go completely mute, (they usually begin to play, to then be interrupted/muted skipping to the actual hit sound), at first I thought it had to be "common" crackling (even if at 60 fps it can happen). As such I tried rising the latency in the SPU2 plugin to 200 ms, switch from XAudio 2 to Directsound as suggested in the guide for DX9 users, etc, without any success. The very fact the issue is so localized to only certain specific sound sets, and that I can rather steadily reproduce it, however, makes me believe the problem might be something completely different.

My current settings:
[Image: spuy.jpg]

Any suggestions? Is this maybe a known nuisance in emulating XS II at the current state of the SPU2 plugin?
It's really something you can just shrug off, as minor glitches such as this are to be expected when emulating, yet it is worth a shot Happy

Sponsored links

The anti-aliasing crash was solved already, but not yet released publicly.

Users browsing this thread: 1 Guest(s)