Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
General Question About Emulator Bugs
#1
Hello everyone. I am semi-familiar with emulators, but completely new to the communities around them.

I was wondering if something is considered a 'bug' if you have to make changes to your settings to get it to go away, and make the game work properly?

For example, I had this 'disappearing world' bug with Ratchet: Deadlocked, where most of the world disappeared or turned black after accessing certain menus, and exiting them. But switching to the Direct3D 11 renderer (from OpenGL) made this problem stop, and now the game runs perfectly fine.

So would this be a bug, or does it get ignored since a simple renderer switch fixed it? Mostly asking just to see if I should put in an official report, and also a bit just to get familiar with the goals of emulator devs.

Thank you!
Reply

Sponsored links

#2
you could report it as a GDSX D3D bug.
but since it's fixed in GDSX OGL, it'll probably be a low priority one
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(02-06-2018, 09:19 AM)jesalvein Wrote: you could report it as a GDSX D3D bug.
but since it's fixed in GDSX OGL, it'll probably be a low priority one

What does 'GDSX' mean? Sorry, not familiar with all acronyms and lingo, yet.

I'm guessing D3D means Direct3D, and OGL is OpenGL. It's actually the other way around (problem was with OGL, fixed with D3D), but I get what you mean in terms of priority, since it's fixable with a bit of reading and a settings change.

Thank you for the quick response Smile
Reply
#4
GSDX is the Graphics plugin
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(02-06-2018, 09:28 AM)jesalvein Wrote: GSDX is the Graphics plugin

Right, right. I probably should have already known that  Wacko

Thanks again, though! Haha.
Reply
#6
It's a known issue relating to Depth emulation. Go to Advanced Settings and Hacks, and click "Disable Depth Emulation" to 'fix' it for OpenGL.
Reply




Users browsing this thread: 1 Guest(s)