Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
God of War 2
#1
Quick question: So when i level up athenas blades (main weapon) to level 3 blades disappear and it causes some bad stuff, I'm using latest svn and tried all settings with no help. I just wanna know if it's known bug or not?

Sponsored links

#2
Dunno if this will work, had you tried setting GSdx to DX9 mode?
#3
Try the Half Pixel offset Hack and try to disable some speedhacks. Reset PCSX2 Back to default.
#4
As I said none of the options hacks fixes this problem. Here's what consol says

(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:00288F4C) TLB Miss, addr=0x1c [load]
(EE pc:0028C02C) TLB Miss, addr=0x1c [load]

looks like bug report but I'm too lazy to do that =)
#5
When you disable speedhacks, make sure you reload your game from NORMAL SAVE, using savestates will just reload the bug.

Such problem happens when the engine code fails awfully, other than speedhacks, manual game fixes(which you should never have enabled, just writing in case;]) and other non-default settings it can be also caused by:
- cheats, if you use any, disable them.
- not using 100% working backup, many popular programs for ripping/editing PC discs(for example Ultra ISO), fails to recreate 100% PS2 game backup, the game often still works fine most of the time, but it can break at some non-random moments cause of that, soo if you used any different one, recreate your ISO with Imgburn which is tested and working properly or at least try using the actual dvd with your original game to play through the broken part to check if it's not just a faulty copy.
#6
Well I've already tried everything what you've suggested except loading from normal save because it's impossible to make normal save in gow2 on pcsx2 (at least on rev I use). I think I'll just go on without updating that weapon lol, that error only appears when I start game upgrade weapon to lvl 3 and unstart game. Only thing left to try is I'll collect enough orbs to update weapon lvl 3 and lvl 4 and try if it works out Smile
#7
Soo you didn't tried anything suggested in this thread in the end, couse reloading the game from normal save is required to check every of those suggestions as using savestates simply keep all bugs you could already have there. >.>

You could try formatting the memory card from bios if the game fails to do so and try a few times couse memory card isn't always detected at first try. I seriously doubt there's any special problem with GOW2 and saving, couse you're first to say this and loads of people finished it on pcsx2, same could be said about the other problem;].
#8
ok thanks miseru I'll try formating mem card from bios and post if it works Smile
#9
Ok I formatted mem card and still can't save game, I think I'll just continue and report back when I'll be able to reach lvl 4. I can try earlier revs but that's not a big problem, it'll just add little more challenge to game Smile
#10
(07-14-2012, 04:32 PM)miseru99 Wrote: When you disable speedhacks, make sure you reload your game from NORMAL SAVE, using savestates will just reload the bug.

Such problem happens when the engine code fails awfully, other than speedhacks, manual game fixes(which you should never have enabled, just writing in case;]) and other non-default settings it can be also caused by:
- cheats, if you use any, disable them.
- not using 100% working backup, many popular programs for ripping/editing PC discs(for example Ultra ISO), fails to recreate 100% PS2 game backup, the game often still works fine most of the time, but it can break at some non-random moments cause of that, soo if you used any different one, recreate your ISO with Imgburn which is tested and working properly or at least try using the actual dvd with your original game to play through the broken part to check if it's not just a faulty copy.

i have Ultra ISO and i never had such a problem it's my favorite ISO maker Tongue

but just for the coincidence i have made this game ISO with Nero ... Laugh

@OP

and what game version do you have ?

if you have a NTSC-U version i can simply give you already made save ?

so where did you reach in the game ?




Users browsing this thread: 1 Guest(s)