Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo 4 Hang
#1
Using pcsx2 1.0 here, with pretty good hardware (Ivy Bridge quad core 3.9 Ghz + Geforce 660 Ti).

Gran Turismo 4 mostly works great in PCSX2, except that it occasionally hangs during races. I eventually got through all the B licenses, but now I'm on the real races that last much longer, and it's really hard to finish one without a hang. It'll just all of a sudden freeze on a certain frame, and it doesn't actually crash, but windows will offer to kill it because it's "not responding".

I've seen some threads where people recommend to downscale the resolution, but.. I'm only using ps2 native resolution, and my video card has a ton of vram, so do I really need to do that (scale to something BELOW ps2 native resolution)? I also enabled 8-bit textures already, but this feels like the wrong path to go down to me.

I've also tried zeroGS, but wasn't too happy with the way the game looked in it.

Can someone recommend what to do here? I'm going to try disabling some of the speedhacks I enabled to see if it helps (EE Cyclerate = 2, VU cycle stealing = 1, enable INTC spin detection, enable wait loop detection, mVU flag hack) but I appreciate anyone's advice.
Reply

Sponsored links

#2
You can try disabling the Allow 8-bit Texture. Disable the VU Cycle Stealing. You can put the EE Cyclerate to 3. (if you want).
GT4 is a demanding game and has high requirements and might Crash sometimes.

if the above doesn't stops the frequent crashes, then try monitoring your PC Temps etc.
Reply
#3
I had the same issue with both GT3 and 4. Got to the track and not only did the game but the emu and my entire PC froze! That was the first time a program froze my entire PC, where I couldn't even Ctrl+Alt+Delete out of it. Got a Core i7 950 OC'ed to 4.0ghz and an nvidia FTW GTX680 w/4GB of VRAM.
Reply
#4
Write all the pc specs maybe the problem is your RAM.
Reply
#5
(09-29-2012, 12:31 PM)theodore7 Wrote: Write all the pc specs maybe the problem is your RAM.

Wouldn't it crash with every program though? My best guess is possibly overheating.
Reply
#6
What revision of PCSX2 are you using? If it's 1.0.0 (or lower) can you please try the latest SVN build and plugins?

Thanks Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
The size of your Ram maybe is the problem. I have weaker pc than yours and i can play these game almost in full speed.
Make sure that you have disable all the hardware hacks in gsdx and especially MSAA set to 0.
Reply
#8
I'm using 1.0.0.0, PC specs are:
Windows 7 (64-bit)
Ivy Bridge 3770K (@3.9 Ghz. turbo, not overclocked)
16GB DDR3 RAM
Geforce 660 Ti
Soundblaster X-Fi

By the way, the game is quite smooth and plays flawlessly for me other than these crashes, so bravo PCSX2 team! :-)

I don't think the issue is overheating because I'm able to play other demanding games (like Battlefield 3, Skyrim, etc.) for hours without ever crashing, whereas this often crashes within 1 or 2 minutes, and it only occurs during races. Also, it never freezes my entire PC, it only freezes the program (and this has happened >10 times). If it were overheating or faulty ram, I think I'd expect other types of crashes too (whole computer freeze, or BSOD, etc.). I also can't imagine too much RAM being a problem, I've never heard of that - it allocates as much as it needs, and the extra shouldn't affect it.

I appreciate the replies everyone - I'll try disabling 8-bit textures, disabling VU cycle stealing, and also try the latest SVN build and plugins when I have time to see if that fixes the issue. I'll also double check my PC temps just in case, and I'll report back on all this when I have time (hopefully tonight).
Reply
#9
OK, just got a chance to try it on latest SVN build (r5423, compiled on Sept. 24th 2012), disabled VU cycle stealing, set EE cyclerate to 2, disabled 8-bit textures, and the crash still occurs. I notice that CPU usage of pcsx2 (in task manager) is at constant 0% while it isn't responding - possible deadlock in the code somewhere? I also just reproduced the hang with ZeroGS, so it seems this is less likely to be related to the video plugin.

Anyway, I'd love suggestions, as I feel like I'm just so close to enjoying this game immensely, if I can just get around this one issue.

Also, CPU temp was 38 C at time of crash, which is not remotely hot (Ivy Bridge is pretty OK up to at least 60 C).
Reply
#10
OK, I solved my own problem, and just wanted to follow up.

It turns out the issue isn't pcsx2's fault at all, it's an occasional hang in my gamepad driver with force feedback. Disabling the force feedback motors fixed the issue for me, and the game runs GREAT!

I'm using my PS2 controller with a Super Joy Box 5 Pro, though I'm going to see if I can try a different version of the driver to resolve the issue, but anyway the issue has nothing to do with pcsx2 at all.
Reply




Users browsing this thread: 1 Guest(s)