Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo 4 Issues with loading
#1
So I have a problem with Gran Turismo 4 right now. After I save my progress, the game just won't let me select cars that I've already driven. I get the error message that the game is corrupted. This has happened three times to me and I even restarted the entire game after getting to 95% completion. I can port my cars over after creating a new save by trading in but that means that the cars are reset to their stock performance and mileage when I first acquire it. I have included a link to download my memory card.
https://1drv.ms/u/s!AgZUtRir2XGs_Gf2ieuE_GPRhN2B
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using, such as speed hacks or presets.
  • Your GSdx graphics settings (a picture of the settings dialog is preferred)
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
Reply
#3
I am running the latest stable version of PCSX2 1.4.0
My PC Specs:
Intel Core i5-3330 (3.0 GHz)
8 GB RAM
Windows 7/8.1/10 (I have three versions of Windows installed and use PCSX2 on all three)
1 TB Hard Drive
Intel Onboard Graphic Card (I know that I can upgrade but I don't have the money).
For custom settings with emulation, I:
-changed the clamping mode of the EE/FPU to Full
-changed the round mode of the EE/FPU to positive
-have the window size setting to 1192x633.

The game I was running is Gran Turismo 4 NTSC-U by an .iso file.


Attached Files Thumbnail(s)
       

.txt   emuLog.txt (Size: 14,25 KB / Downloads: 18)
Reply
#4
You should not change the EE/IOP settings in this game, did you try the game with the default values?
Reply
#5
I know for sure that the clamping mode is safe as I've tested it many times. I changed it so everything like sector time, how many seconds I'm ahead or behind and who is pitting can all be displayed (it's a graphical glitch). As for the round mode, I could try testing back to zero. I'll edit this post when I get the chance to tweak the settings.

(Edit) Okay, I found out it's a bug. When I set the round mode to zero, the cars can be loaded. When I set it to positive, the game gives you a panic attack that your game data is corrupted. How can I submit this as a bug then?
Reply
#6
Any reason why are you changing the default EE/IOP settings
The default option is Crop/Zero and I don't think your bug report will be accepted because those options should be changed only if you know that they are fixing something
And also pcsx2 can't play all games without changing some settings yet,that's why there are couple of setting managers here.
Reply
#7
Quote:Demo races do not work
  • Status: Active

  • Type: Minor

  • Description: Demonstrations return back to the menu as soon as they start.

  • Workaround: Go to Config -> Emulation Settings -> EE/IOP and set Clamping Mode to "Full". However, this will make other events fail to load, requiring it to be set back to Normal after the Demonstration.

Via: https://wiki.pcsx2.net/Gran_Turismo_4
I think that is one of your issues. Second is that should update PCSX2 to latest version ,where heavy crashes mentioned on wiki, are partially fixed.
Reply
#8
Yep, GT4 is very picky about rounding and clamping modes and changing them from the required mode is going to be a user problem, not a valid bug. For EE, you should have Chop/Zero for Rounding Mode and Full for Clamping mode. For VU, Chop/Zero for Rounding and Extra + Preserve Sign for Clamping.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
#9
I was toying around with the settings so I can improve emulation speed. I use software renderer. For most races, it runs in full 60 fps. However for night tracks like Special Stage Route 5 and George V Paris, it runs very slow (30-35 fps). When I change the camera view, it increases by about 10 fps. Please don't bother me with upgrading my PC as I don't have the money.
Reply
#10
Did you upgrade PCSX2 yet? Get the latest version here: https://buildbot.orphis.net/pcsx2/
Reply




Users browsing this thread: 1 Guest(s)