Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo 4 Weird Graphics
#1
Hi all,

I've just been playing Gran Turismo 4 after quite a while, and I've noticed some things that I haven't noticed before. 

One of the things I've noticed is that the wheels on the player's car are a strange looking mess, but not on the ghost car. It happens on cars other than this one; it happened yesterday on the Formula Gran Turismo at Fuji. Here's what I mean:
[Image: fAKNWyW.png]

[Image: YLWA3EV.png]
As you can see, the ghost car's wheels are fine whereas my wheels are just an odd mess. 

Another thing I've noticed is that the replays seem to go weird at certain areas. I can't say if this is true for every track, but it definitely happens at the Circuit de la Sarthe. Here's me bombing it down the Mulsanne:
[Image: jXRRhs0.png]
Not that you can tell it's me bombing it down the Mulsanne or anything... Because the only thing you can see is the HUD! This corrects itself when a new scene is shown, but then happens at other intervals on the track.

EDIT:
It happens with the AI too:
[Image: ghPkHez.png]
Intel i5 4460 @ 3.20 GHz,
GTX 1050 Ti,
8GB RAM,
And some other gubbins that make things work.
Reply

Sponsored links

#2
are you using any speedhacks or game fixes? The wheel glitch is a timing dependent thing, so any of the forementioned things being used could throw it out.

Also what version of PCSX2 are you using?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(04-15-2018, 10:19 PM)refraction Wrote: are you using any speedhacks or game fixes? The wheel glitch is a timing dependent thing, so any of the forementioned things being used could throw it out.

Also what version of PCSX2 are you using?

Yeah, I've got the EE cyclerate set to -1 with MTVU enabled. However, I've always used these settings for this game with no issues.
I'm currently on the 23rd March 2018 build... Would getting the recent Git make much difference? It seems like it's a new Git that's caused this after all.
Intel i5 4460 @ 3.20 GHz,
GTX 1050 Ti,
8GB RAM,
And some other gubbins that make things work.
Reply
#4
Ah, I remember this glitch, IIRC it's related to the texture filtering used - one of the settings causes this.

Edit: Actually I believe having 8-bit textures enabled or disabled causes this...
Reply
#5
(04-15-2018, 10:23 PM)CK1 Wrote: Ah, I remember this glitch, IIRC it's related to the texture filtering used - one of the settings causes this.

Edit: Actually I believe having 8-bit textures enabled or disabled causes this...

Just tried with and without 8-bit textures enabled and there's no difference. My GSDx settings are literally the same as they were the last time I played this without these things happening.
Intel i5 4460 @ 3.20 GHz,
GTX 1050 Ti,
8GB RAM,
And some other gubbins that make things work.
Reply
#6
(04-15-2018, 10:23 PM)Kian Stevens Wrote: Yeah, I've got the EE cyclerate set to -1 with MTVU enabled. However, I've always used these settings for this game with no issues.
I'm currently on the 23rd March 2018 build... Would getting the recent Git make much difference? It seems like it's a new Git that's caused this after all.

You could try a newer one, if not, try an older one. If you could trace where it broke if it is a newer build that caused it, that would be super helpful

Edit: Just to rule something out, can you try builds 2263 and see if it then breaks in 2264? Thanks

Edit 2: Hmm I can't get it to go wrong on the latest git, replays worked fine too, so maybe updating would be a good idea.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(04-15-2018, 10:36 PM)refraction Wrote: You could try a newer one, if not, try an older one. If you could trace where it broke if it is a newer build that caused it, that would be super helpful

Edit: Just to rule something out, can you try builds 2263 and see if it then breaks in 2264? Thanks

Edit 2: Hmm I can't get it to go wrong on the latest git, so maybe updating would be a good idea.

I think I've found the culprit.
There wasn't a regression from previous builds, it was me... I enabled skipdraw since some of my games need it to look normal. Looks like I forgot to disable it Tongue
Intel i5 4460 @ 3.20 GHz,
GTX 1050 Ti,
8GB RAM,
And some other gubbins that make things work.
Reply
#8
Well done Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
I want my 30 mins of testing back.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#10
(04-15-2018, 11:22 PM)lightningterror Wrote: I want my 30 mins of testing back.

And mine, I did exactly the same thing haha
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)