Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo 4 graphical issues
#1
Hi.

GT4 works very nice on my PC (framerate-wise).
However, there are some graphical bugs that bother me.

For example, the game doesn't show split times for me. Ever.

At the start of races (or licence tests), when it counts down and the camera swings by the car a couple of times, I get a glitch.
3 and 2 work flawlessly, but just as it's about to show the last countdown second, it freezes for about 2 seconds, shows a lot of artifacts and then goes on working properly (and looking properly, the artifacts just show up for a fragment of a second).
It's not really that big of a deal (honestly, I'm thrilled that the games works this good), but if there's a solution...

Also, ghosting doesn't work. As in, ghost cars in licence trials.

Thanks in advance! Smile
Reply

Sponsored links

#2
You should post you settings if you want to ask stuff like this.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#3
Plus your PC specs...
Reply
#4
Oh, sorry, I forgot. I'm not really sure which settings are important...

Emulation Settings
EE/IOP: Everything default
VUs: Clamping Mode set to Extra. The rest is default.
GS: Default
GS Window: Default
Speedhacks: mVU Flag Hack and MTVU checked. The rest is default.
Game fixes: Default

Plugin/BIOS selector
GS: GSdx 5334 (MSVC 16.00, SSE41) 0.1.16 [gsdx32-sse4-r5350]
Configuration for that:
Renderer: Direct3D11 (Hardware)
Interlacing: Auto
Scaling: 4x Native
The rest is default.

PC Specs
Intel i5 [email protected]
8GB RAM
nVidia GTX670 2GB

I know, I know, 4x scaling is pushing it, but there's a noticeable difference in quality and the game still runs smooth, so why not. Mind you, I have the PAL version of the game, which doesn't support 480p or 1080i.
4x scaling is probably why the game freezes for a couple of seconds at the start of every race, but even when leave the game running at its native resolution, I get the same kind of artifacts and glitches (but the freezing is far less severe).

The other GUI problems (like not displaying split times) persist no matter which resolution I pick.
Reply
#5
Have you tried going x3 instead of x4 scaling? Enabled 8 bit textures, and texture filtering? Did you enable any HW Hacks? I haven't really tested this game though (I will as soon as I burn my game into an ISO)... >_> Got 100+ PS2 games but I can only store a few at any given time on my PC's HDD.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#6
As I said, lower scaling does make the freezes considerably shorter, but the artifacts persist.
But that's not really that big of a deal. I can definitely live with that.

I'm more interested in getting the game to show all the GUI elements properly.

I haven't enabled any HW hacks... I'm not really sure if any of them would help.
Will try, though.
Reply
#7
GT4 has extreme video memory usage problems, i wouldnt recommend running it in anything above native res, maybe native x2 if you're really lucky (should be ok on your card).
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
GT4 runs fine on 2x int on much slower 512mb video card. He has 2GB video memory and faster card. I dont see problem to run at least 3x int. But i also think that 4x int is too much. I dont see difference between 3x and 4x in this game.
Reply
#9
Hello,
I don't mean to hijack this thread, but has anybody solved this problem where the ghost car in licence trials just stands there and does not move at all?
(08-17-2012, 03:36 PM)Ixy Wrote: Also, ghosting doesn't work. As in, ghost cars in licence trials.


And I also have this short freeze just before I can drive the car at the start of the race but it does not bother me.

My PC specs:
Xeon W3520 @ 4.2GHz, 12GB RAM, GTX670 2GB

All PCSX2 settings are at default values, except for scaling which is set to 4x
Reply




Users browsing this thread: 1 Guest(s)