Gran Turismo 4 is very choppy on ''good'' PC
#1
I'm having some framerate issues with Gran Turismo 4 and i can't figure out why, even at the lowest settings it plays the same, EE% rarely goes over 55% and the GS% sitts at around 50%.

I've tried putting the settings to the lowest they will go but that didn't change anything, I have also tried fiddeling around with the speedhacks but still no inprovements. It almost feels like there is some ''hidden'' box that needs to be unchecked or something but that usually isn't the case.

The game is also running at a constant 60fps with speedhacks off so the fps counter in the top left should be reading correctly, but the game feels closer to maybe 40 fps.
(edit)   
I wanted to elaborate a bit since i noticed that the game runs fine almost completely fine aslong as the car isn't turning, another thing i noticed is that the game seems to get a bit more pixilated after a few more seconds, this is very bizzare to me.






My specs are:

Gtx 1080.

Intel core i7 7700.

16GB of 2400mhz ram.

I'm running  the game at 1080p.

I should also add that i'm using the Ntcs version of the game.

If you have any suggestions i would love to try them since this game is a lot of fun even with the framerate issues.
Reply

Sponsored links

#2
did you set windows power plan to high perfomance mode ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#3
(02-16-2022, 10:59 PM)jesalvein Wrote: did you set windows power plan to high perfomance mode ?

Yup, but perhaps the windows game mode thing could be causing problems?
Reply
#4
(02-16-2022, 10:11 PM)Zkybi Wrote: (edit)   
I wanted to elaborate a bit since i noticed that the game runs fine almost completely fine aslong as the car isn't turning, another thing i noticed is that the game seems to get a bit more pixilated after a few more seconds, this is very bizzare to me.

https://forums.pcsx2.net/Thread-Accurate...S-big-time
I don't know if this is not fixed on the letest beta
Reply
#5
Any ideas anyone?
Reply
#6
nvidia whisper mode, maybe ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#7
(02-21-2022, 10:05 AM)jesalvein Wrote: nvidia whisper mode, maybe ?

no, but could running the game from an iso bring negative effects? just a blind guess.
Reply
#8
if you made it from your dvd using imgburn, no.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#9
(02-21-2022, 10:25 AM)jesalvein Wrote: if you made it from your dvd using imgburn, no.
Then that shouldn't be a problem then.
Reply
#10
The main think that im really wondering at this point is why the game claims to be running at 60fps, all speedhacks are off except for the recommended ones so it should give the correct fps numbers but the game isn't running at said framerate. I'm really just curious since i have emulated this game a few years ago using an older version of pcsx2 and i don't recall it running like this but i could be very wrong since this was back in 2017 or maybe 18.
Reply




Users browsing this thread: 3 Guest(s)