Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Grand Theft Auto Vice City working
Does anyone know what gets you past the initial loading screen? I can't figure out what it was... Sad

Using NTSC on PCSX2 0.9.8 (r4600).

Sponsored links

What it was?
Did it work before? If so I'd like to know when it did. It's been the same for long time now, I had a patch to go ingame but broke other things...
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Yes, I managed to get ingame with the new beta (official, unpatched). Honestly, I was sitting at the loading screen just trying different things, and then I noticed it continued loading all of the sudden. I can't for the life of me figure out what it was that did it. The settings in place at the time were quite extensive, so I'm guessing it wasn't everything I had applied...

At least I still have a savestate right when you assume control. Smile
Nice, could you upload that savestate? Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Well, if it was anyone else asking... Wink

GTA VC - Game Start savestate.
Well, don't that beat all... Sometimes in life, it's the simple things. Like Clamping on "None" in the EE/IOP settings, and a bit of patients. Wink

That's all it takes to get through that loading screen with PCSX2 0.9.8. The first time I got past it, I had the framelimiter on and was running @ 60fps during the loading screen, and that did take a while (enough time to not see the effect of clamping before I'd changed too many settings to know what did it! lol). So, I took the smart approach, turned off framelimiting (for faster results), and then it only takes about 4 minutes @ 240fps. At that point, I just had to begin taking away all the changes I had made (one by one) until I pin-pointed which single setting did it.

Horray for closure!

I did try this approach on 0.9.7 r3878, but got nowhere. It really was a change in the 0.9.8 r4600 release (or somewhere in between). Good job, team! You never fail to put a smile on my face when you fix stuff. Smile
Intetesting..... so if you have any clamping on the ee it doesn't boot?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Actually it's a bit more complicated than that...

I tried this last night and found it's a bit random...
It needs "EE Timing Hack" or it'll take a long while to enter (or won't enter at all maybe), in fact if you edit the ecycles for EETimingHack to something bigger (28 instead of 8 is what I tried Tongue2) it may take just a few seconds to enter, also likes "EE cycle rate x2" speedhack. Even with that it may not boot at all but it's like a 25% chance it does and only when the loading screen starts with the white guy (forgot his name) and still does a few loops before it continues when it shouldn't...

Something wacky is going on but once it's in it's stable Tongue2
Also once you're inside the same loop can be reproduced if you go in the options and try to change the audio output from Stereo to DTS.

I guess for now people could play it with a savestate once you can move around in the game since you can manage memcard load/saves there. It's a weird problem and way too random tho Oo
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Going off the high pitched squeal when it hangs, does spu2 plugin make a difference?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Seems only recent SPU2-X go in, the release SPU2-X 1.4 doesn't.

Also... I tried going in with a new 8MB memory card and it doesn't seem to go with that either, but my old big card go in, ionno Tongue2

Edit: Oh also when ingame and going into options > load memcard screen it's pretty slow there...
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64

Users browsing this thread: 1 Guest(s)