Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphic Issues with stretching of sprites.
#1
Hi there, my first time posting on the the forum.

I'm attempted to get high quality sprites out of the game Fire Pro Wrestling Returns. I'm having trouble though because no matter what graphic settings I use, there seems to always be a form of anti-aliasing being done to the display. I'm trying to get the most pure sprites possible from this game for a side project involving pixel art.

[Image: 9cd50dc20b.png]

Here is a SS of me working on it in PhotoShop. As you can see, there a layer of pixels around the sprite that appear to be semi-transparent. I think this is because of a blending option in the emulator, but even when I turn everything off, this effect remains. I'm almost ready to buy it on the PS3 PSN store just to make sure this isn't a sprite problem in the game, and actually a issue with the emulator.

Here is a SS of my video plugin settings.

[Image: 4f2ad56379.png]

Any help at all would be appreciated.
Reply

Sponsored links

#2
I haven't used the emulator in quite a while, but try allowing 8bit textures, and perhaps upscale.
Reply
#3
(11-26-2014, 09:53 AM)Rassane Wrote: I haven't used the emulator in quite a while, but try allowing 8bit textures, and perhaps upscale.

Would upscaling distort the sprites? Ideally I would just rip them from the game, but that seems very difficult to do with PS2 games.

Turning on 8 bit textures didn't seem to have much of an effect.

[Image: 62bee6e789.png]

Here is changed the ring to a bright magenta to help the problem stand out. This one is taken with the same settings as before, but with 8-bit textures turned on. The outline board of pixels I have highlighted are the problem, they are semi-transparent.
Reply
#4
Try to cycle through the different interlace options with F5 and see if that helps.
Reply
#5
ahem *cough* use the software mode. Rolleyes

if that doesn't do it, then that's how that renders.
Reply
#6
So after much fussing with this, it looks like it is just how the game renders its sprites, which is disappointing because the other versions of the game like the on on DreamCast has a hard edge to the sprites without any blending.

I've found a way around it using photoshop by filtering out the magenta, but it is still a pain to deal with. Thank you all for your assistance. Here are some more sprite rips I did using my new method in case you are curious.

[Image: ebaa3ace8b.png]
Reply
#7
Okay, if your method works then it's fine.
You could try and hack the rendering in GSdx if you want to, though.
There must be some way to "disable" the PS2 typical blurring.
Reply
#8
I'm sure you tried this but:

Make sure your GSdx window is EXACTLY the size of your GSdx resolution. Otherwise it would have to be resized, which would use a bilinear filter, and cause this.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply




Users browsing this thread: 1 Guest(s)