Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphic glitch in KH
I'm totally new to PS2 emulation, and decided to try it. To start, I tried Kingdom Hearts and soon I will try FFX. But when I played KH, I found 2 problems.

I played the game in the beginning normally, with constantly 60fps (NTSC version). Then, the game fps dropped to 60%-80% after the tutorial part, nothing uncommon (as far as I know) since I looked at the forums and saw a lot of ppl with fps drop in KH. I changed some graphics config and got better results at all.

But, besides the fps problem, I got a graphical glitch in the beach area (right after the tutorial part of the game), where the game was a lil bit "broken", some parts with texture, others with nothing, like an empty space. I don't know exactly how to explain, but the sea and sky texture where broken, like pieces, and the scenario itself was messy, the only thing great was the characters.

I searched the forums and see no other one with this problem.

I'm using a Quad Core 2.44ghz, a geforce 9600 512mb and the Windows XP SP2.
I'm using the 0.9.6 version of PCSX2, together with the latest plugins.
The graphics plugin is the GSdx (latest edition to the date, downloaded in the oficial thread), Resolution: Windowed, Renderer: Directx3D9 (Hardware), Interlacing: None, Aspect Ratio: 4:3, D3D internal res: native or not (I changed this to get better FPS), with Texture Filtering (marked), Logarithmic Z (marked) Alpha Correction (FBA) (marked), Enable output merger blur effect (marked) and Wait vsync (unmarked).
I tried to change the emu version to the beta build and also the graphics plugins, but with no great results for the glitch.

So, what is this glitch, is it a bug or a problem due to the especification of my PC (hardware and software) and what can I do to solve it?

Sponsored links

I just tested it and you're right. The bug is caused by the latest GSdx,so get in the GSdx thread and get the latest stable release 0.1.14. That should fix it
[Image: newsig.jpg]
(06-13-2009, 09:41 AM)Bositman Wrote: I just tested it and you're right. The bug is caused by the latest GSdx,so get in the GSdx thread and get the latest stable release 0.1.14. That should fix it

Yeah Bositman, it worked. Really thanks.

But I still have some doubts about solving the FPS problem. The game runs perfectly in "closed" moments, but during some cutscenes and during the gameplay in parts where shows larger areas (with a lot of objects) I got some slowdowns to 40 FPS.

I already tried the speedhacks (2x cycle), marking native resolution and changing the emu version (from 0.9.6 to the latest beta build). Is there something for me to do to get a solution or the FPS drop is expected due to my hardware limitations (first post)?
Slowdowns is highly expected in such places, really -- to many instructions should be recompiled. At the end scenes of this game slowdowns would be bigger. Also Whale location could give a slow.
Great, the hlsl compiler has a problem with switch...

Even simplified down to this and still can't see it:

case 3:
  uv.x = tex1D(UMSKFIX, uv.x);
  uv.y = tex1D(VMSKFIX, uv.y);
  uv.z = tex1D(UMSKFIX, uv.z);
  uv.w = tex1D(VMSKFIX, uv.w);
  return uv;
And if you add a [branch] attribute before switch (that it should be equal to if statement)?

Users browsing this thread: 1 Guest(s)