Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphic glitch on Ratchet Deadlocked
#1
Wink 
Hello,


I'm having a week break from work and I decided to play my old games on my new PC :

Operating System =  Microsoft Windows 10 Home (build 17134), 64-bit
Physical RAM     =  8069 MB
CPU name         =  Intel® Core™ i5-8250U CPU @ 1.60GHz
Vendor/Model     =  GenuineIntel (stepping 0A)
CPU speed        =  1.799 ghz (8 logical threads)
GPU  = Intel (HD) Graphics 200 + Nvidia GeForce MX150

I downloaded Pcsx2 1.4.0, here are my settings :
 [Image: pcsx2_App_Settings_Plugins.png]
I first used my Nvidia card with Direct3D11 (Hardware) and I could play my Dragon Ball B. Tenkaichi 3 just fine with everything else at default. Later on, when i tried my Ratchet Deadlocked, it was horribly slow (~30 fps), I had to play with the speedhacks:
[Image: pcsx2_Core_Settings_Speedhacks.png]
But I got it to run at full speed. The objects were a bit glitchy from afar but were rendered well when I got close to them, that wasn't that much of an issue.

My problem started on the second planet, when there's a scenery, mountains and such to draw, I started having red lines across my screen. Playing with the settings a bit I realized with Open GL(Hardware) as the renderer and by checking Hardware depth, the red lines would go away for the price of fewer than 3 fps so that was great. I thought I was finally good to go when I realized that pressing start or going into the vendor screen triggered a weird glitch where everything on the screen disappears.
I tried testing the latest dev build (the 1.5.0 I believe) with the same settings and first, it reminded me that at the menu screen there should be a background image which wasn't appearing on 1.4.0, second, the rendering of every object was good now, whether close or far but that glitch is still here. I can't pause the game nor buy stuff. Whenever I do, I have to restart the challenge. There is a very slight slow down when too many things explode on screen too, that I don't mind at all but when I have to answer my phone and the screen turns to this :
[Image: Capture.png]
It is annoying.

I've tried playing with the settings or close to 40 mins now and I'm giving up.

Here's the emulog from the sequence " Opening Emu -> Loading game -> Loading Savestate in mission -> Pressing Start -> Back to the glitched screen -> Turn off the game "
Code:
 Loading plugins from C:\Users\berty\Documents\pcsx2-v1.5.0-dev-2427-gf41e5da94-windows-x86\plugins...
Bound   GS: GSdx32-AVX2.dll [GSdx 20180628180810 (MSVC 19.00 AVX2/AVX2) 1.1.0]
Bound  PAD: LilyPad.dll [LilyPad (20180628180810) 0.12.1]
Bound SPU2: Spu2-X.dll [SPU2-X 20180628180810 2.0.0]
Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20180628180810 0.11.0]
Bound  USB: USBnull.dll [USBnull Driver 20180628180810 0.7.0]
Bound   FW: FWnull.dll [FWnull Driver 20180628180810 0.7.0]
Bound DEV9: DEV9null.dll [DEV9null Driver 20180628180810 0.5.0]
Plugins loaded successfully.

(GameDB) 9594 games on record (loaded in 305ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Users\berty\Documents\Ratchet - Deadlocked (USA) (En,Fr,Es).iso
Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (2127392 sectors)
Opening USB
Opening FW
Opening DEV9
3.x GL context successfully created
OpenGL information. GPU: GeForce MX150/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 388.73
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_viewport_array is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_direct_state_access is available
INFO: GL_ARB_texture_barrier is available
INFO: GL_ARB_get_texture_sub_image is available

Current Renderer: OpenGL (Hardware renderer)
Available VRAM/RAM:3840MB for textures
GSdx Lookup CRC:0
McdSlot 0 [File]: C:\Users\berty\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\berty\Documents\PCSX2\memcards\Mcd002.ps2
GSdx Lookup CRC:0
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA     v02.20(10/02/2006)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
# Initialize memory (rev:3.70, ctm:196Mhz, cpuclk:147Mhz detected)

PlayStation 2 ======== Hard reset boot
 ROMGEN=2006-0210, IOP info (CPUID=1f, CACH_CONFIG=14000200, 2MB, IOP mode)
 <20060210-142424,ROMconf,PS20220WC20060210.bin:11824>
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Apr  7 2005 21:09:14
  CPUID=2e20, BoardID=0, ROMGEN=2006-0210, 32M

Patches: No CRC found, using 00000000 instead.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.65;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_974.65;1) Game CRC = 0x9BFBCD42, EntryPoint = 0x00800008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.65;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc. 
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15) 
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SCUS_974.65;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SCUS_974.65;1
0 00800000 0019c03f ..........................
Loaded, cdrom0:¥SCUS_974.65;1
start address 0x800008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Elf entry point @ 0x00800008 about to get recompiled. Load patches first.
GSdx Lookup CRC:9BFBCD42
GSdx Lookup CRC:9BFBCD42
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 (C) Sony Computer Entertainment Inc. 
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15) 
iop heap service (99/11/03)

==========================================================
 989snd (c)2000-2003 Sony Computer Entertainment America
 by Buzz Burrowes                               v3.1.7
                        (built May 10 2005 at 19:36:08)

 NO MIDI VERSION! No MIDI, AME, or basic VAG sounds
                  (banks and streams only)

 (build with sce library rev 3.0.1)
==========================================================
    Thread Priorities:
                         Sound Tick = 9
                           Main RPC = 58
                        Loading RPC = 59
                          Streaming = 60, 61, 62, 63
==========================================================

Loading savestate from slot 0...
filename: C:\Users\berty\Documents\pcsx2-v1.5.0-dev-2427-gf41e5da94-windows-x86\sstates\SCUS-97465 (9BFBCD42).00.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2
MTVU speedhack is enabled, saved states may not be stable
[17:20:10.354] Auto-ejecting memcard [port:0, slot:0]
[17:20:13.372] Re-inserting auto-ejected memcard [port:0, slot:0]
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Delete 0 Shaders, 64 Programs, 28 Pipelines
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(GameDB) Unloading...

I geniunely love this game so I truly hope someone can help.

Little side question: I realized that with OpenGL, Tenkaichi 3 looks smoother and the sparks on the aura & gauge when maxed works, problem is I lose like 12 fps for that so there's an input delay. Is there a special setting or Has there been any patch I'm not aware of ?

Sponsored links

#2
The disappearing graphics issue in Ratchet: Deadlocked can be prevented by enabling "Fast Texture Invalidation" under GSdx Settings → Advanced Settings and Hacks. If the glitch has already occurred, it can't be fixed without rebooting the game / loading a memory card save.

If you made a save state after the issue has occurred, the issue will persist if you load that save state (even after changing settings and rebooting) - you will need to load a memory card save.
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


#3
(06-29-2018, 07:22 PM)Dreadmoth Wrote: The disappearing graphics issue in Ratchet: Deadlocked can be prevented by enabling "Fast Texture Invalidation" under GSdx Settings → Advanced Settings and Hacks. If the glitch has already occurred, it can't be fixed without rebooting the game / loading a memory card save.

If you made a save state after the issue has occurred, the issue will persist if you load that save state (even after changing settings and rebooting) - you will need to load a memory card save.

I checked so many options at random, even in the Advanced Settings and Hacks and one check was all it took. Funny, frustrating but laughable.

Anyway, it worked and there seems to be no other issue, so thanks a lot for the quick answer.

( And if I may, any idea how to bring back the sparks on Tenkaichi 3 while using Direct 3D11 Hardware ? )
#4
I can't speak absolutes but just going off general knowledge it may not be possible. The DX11 renderer is limited by a smaller feature set than that available to OpenGL, and as such fewer game effects can be properly emulated with it. DX9 is an even worse case of this. You will find that when using the DX renderers, some effects, often times lighting, bloom or various types of "blending" or "filter" effects get missed.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

#5
I see, that's too bad but the game is definitely still enjoyable so it's alright. Thanks for the answer.

( How do I close this thread again? )




Users browsing this thread: 1 Guest(s)