Graphical Display Problem?
Whenever I try to play a game, the screen blacks out then Windows tells me that Display Driver XP® has stopped working and has recovered.The video doesn't load unless I reset it, but the sound still works. The FPS remains around the 50-60 area, so I doubt it's a processing issue. I bought this laptop last month, and PCSX2 worked perfectly fine (albeit slow) in my dated Vista computer.

CPU- Intel® Core™ i3 CPU @2.40GHz (4CPUs)
Graphics Card- Intel® HD Graphics (Core i3) 1751 total memory)
Ram: 4.1 MB
OS: Windows 7 64bit

Version: 1.2.1

Games I tried:

Silent Hill 2: After the PS2 Logo, the driver crashes, but I could still hear the intro
Person 4: Driver crashes after logo, but I could the intro as well
Kingdom Hearts: Driver crashes after I pick any option at the Title Screen

Using it through ISO as well.

Help is very much appreciated.

Sponsored links

Care to post the emulog.txt after a crash ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
For Persona 4:

PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition (build 7600), 64-bit
Physical RAM = 3758 MB
CPU name = Intel® Core™ i3 CPU M 370 @ 2.40GHz
Vendor/Model = GenuineIntel (stepping 05)
CPU speed = 2.394 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 009ae3bd
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\plugins\gsdx32-sse4-r5875.dll
Windows 6.1.7600
Binding PAD: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\plugins\lilypad-r5875.dll
Binding SPU2: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\plugins\spu2-x-r5875.dll
Binding CDVD: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\plugins\cdvdGigaherz.dll
Binding USB: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\plugins\USBnull.dll
Binding FW: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\plugins\FWnull.dll
Binding DEV9: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 313ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Windows 6.1.7600
Init PAD
Init SPU2
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Users\Gilgamesh\Downloads\PS2 Roms\Persona 4 [PAL] [PS2] []\lcl-p4p2\persona4.pal.ps2.iso
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2151360 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Gilgamesh\Downloads\Emulators\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v02.20(10/02/2006) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_554.74;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SLES_554.74;1) Game CRC = 0x117D1977, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_554.74;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
(GameDB) Enabled Gamefix: VuClipFlagHack
EE/iR5900-32 Recompiler Reset
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
And for elaboration, PCSX2 doesn't crash, only my Display Driver. PCSX2 still runs after it recovers, the screen is just black.

Not sure how related the two are, though.
Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)