Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphical bugs when running Jak 3 on software mode
#21
There are various texture cache issue like R&C actually. The bad color is a random texture data. Could be a core bug too or maybe a wrong palette upload.
Reply

Sponsored links

#22
Texture cache, of course. That doesn't sound good.
Reply
#23
I merge a branch that fix some issue on palette management. Maybe you could give a quick trial. Unlikely to fix anything but you know sometimes it happens
Reply
#24
(09-27-2016, 10:09 AM)gregory Wrote: There are various texture cache issue like R&C actually. The bad color is a random texture data. Could be a core bug too or maybe a wrong palette upload.

I didn't know texture cache could affect the software renderer, I thought it only affected HW mode. Huh
Reply
#25
Well it is complicated. I will try to look later after some mipmap stuff.
Reply
#26
See latest post
https://github.com/PCSX2/pcsx2/issues/1561

I have a proof there is some bug in the texture mapping on mipmap stuff.
Reply
#27
So maybe this was not texture cache related?
Reply
#28
Here the visual of the bug.

So the game does a copy of the palette with a draw call (aka GS write).

On the right you have the input texture. On the left panel (top left corner), you have the blitted palette which ough to be a copy.

On HW:
* We don't support GS write to the palette. Multiple games are affected, it would be nice to find a solution or maybe a way to invalidate the texure (potentially with a hack)

On SW:
* as you can see, there is a rounding issue, the palette seems to be shifted by 1 pixels.

Edit: the block is 16x16 pixels. And texure coordinate range from 0 to 1. Which I think is translated to [0;16] range (17 texels) and GS rounding will likely take only 16.


Attached Files Thumbnail(s)
   
Reply
#29
Is it the only jak affected?
Reply
#30
Jak II has the same issue, but it is less noticeable.
Reply




Users browsing this thread: 1 Guest(s)