Graphical corruption on Mint 17 with open source drivers
Hello. I am running Mint 17 and using the mesa drivers for my AMD Radeon HD 7950. I use the Oibaf PPA which currently supports openGL 3.3. When I run any game on PCSX2, I experience corruption. GSDX with openGL hardware produces no video but it has sound. GSDX with openGL software has the video in a very small window in the top right of the screen and corruption around the rest. Picture of that: If I use ZZZ Ogl PG 0.4, I get really bad corruption too. Picture:

What is going on?

Sponsored links

For GSdx, could you disable Geometry shader in the config
Hi gregory.
I just tried and I experience the same problems. When checking the stdout errors, it reports they are auto-disabled because it thinks my graphics drivers are "buggy". Is this the cause, and why is this the case?

Here is relevant info:
glX-Version 1.4 with Direct Rendering
Supported Opengl version: 3.3 (Core Profile) Mesa 10.3.0-devel (git-e974781 trusty-oibaf-ppa) on GPU: Gallium 0.4 on AMD TAHITI. Vendor: X.Org
Note: the maximal version supported by GSdx is 3.3 (even if you driver support more)!
Buggy driver detected. Geometry shaders will be disabled
Override geometry shaders detection

INFO: GL_ARB_separate_shader_objects is supported
INFO: GL_ARB_gpu_shader5 is not supported
INFO: GL_ARB_shader_image_load_store is not supported
INFO: GL_ARB_clear_texture is not supported
INFO: GL_ARB_buffer_storage is supported
INFO: GL_ARB_shader_subroutine is not supported
INFO: GL_ARB_explicit_uniform_location is supported
INFO: GL_ARB_texture_storage is supported
INFO: GL_ARB_shading_language_420pack is supported
INFO: GL_ARB_multi_bind is supported
INFO: GL_ARB_bindless_texture is not supported
INFO: GL_NV_depth_buffer_float is not supported
Force-disable seperate shader in GSdx advanced config.
(06-20-2014, 11:42 PM)agent00skid Wrote: Force-disable seperate shader in GSdx advanced config.

Wow, that fixed both of my probems. Thanks alot!

Users browsing this thread: 1 Guest(s)