Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gsdx Hardware Rendering problem
Ok. Just install apitrace 32 bits and try to replay this short trace and tell me it begin to draw a white scene

Sponsored links

Well, the SDL patch seems to work great for fixing my sound problems. I think there's still a bit of delay, but it's minuscule enough now that lip syncing doesn't bother me. I'll watch some more tomorrow as I'm continuing through FFX. I'll post a comment in the issue after that.

Had a bit of trouble getting apitrace installed. Was missing some 32-bit deps and the cmake script wasn't telling me...
The replay flashed a white screen and that was it. And I got a console full of errors. See ffxii.log.xz. I grabbed a trace of what I'm seeing (well, not seeing) in the first couple seconds of the intro and attached it as well (ffxii_nvidia.trace.xz).

Are you sure that you reset override option to -1?

Or Apitrace screw up the opengl setup!
Yeah, I noticed that the trace of yours that I replayed had the same errors as when I had set the overrides. But that was the trace replay, so I don't think there are any options I can set.
And for the trace I made, yes. Attached is my GSdx.ini.

OK I got it. Nvidia and AMD don't have the same GLSL spec.... (imagine with the additional free driver how messy it can be). Anyway forget about it. Your trace is working on my PC. You are able to replay it right. Now remains to find the bug! Will explain later how to use apitrace, in short we need to compare input/output of drawcall of frame 562/563 (frame that actually render a grey rectangle with bottom/top dark border).

Edit: it might worth to disable geometry shader override_geometry_shader => 0. (then regenerate the trace). Set resolution to native. It would reduce shader complexity by 2.
Yuck. Differing specs. That's one reason I want to see radeon and nouveau catch up to the proprietary drivers in the 3d acceleration space. They have the unified api, but not the performance. Though, I'm surprised the Kronos glsl spec doesn't have enough core functionality to get this job done.

New attachment with a trace. I set nativeres -> 1 and the geometry shader -> 0. I'm glad these traces compress well...


Edit: Wait... bad trace. Wrong renderer. Back in a sec.

Edit 2: You might have just accidentally hit it on the head. I have the intro video with native res and no geometry shader. I don't have time to continue the test right now, but I'll be back at it in an hour or so.
I mean the core glsl spec of khronos. AMD glsl is full of bug, typically they don t follow version number for the syntax.
Oh, fun.

My last post has several edits. And I had a couple more minutes than expected. So, I ran XII further and double checked X. They both are rendering characters fine in game. Looks like the bug is in the internal res resize. Now I'm gone for an hour or so, then I can continue with anything more you need.

Don t worry I still need to work :-P Anyway, can you test if the issue is in the resolution scaling or geometry shaders, just to be sure.
Okay, testing with FFX. It's the geometry shader. Setting it back to autodetect causes my problems. I can set nativeres -> 0 and almost everything displays correctly. Doing that introduced some thin black lines around parts of the in-game menu, but that's a small problem compared to the other right now. What's the geometry shader used for?


Users browsing this thread: 1 Guest(s)