Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HDTV Xploder Progressive video modes.
#1
Does anybody know why HDTV Xploder doesn't set gsIsFrameMode to Frame for it's 480p, 576p & 720p video modes,
it's still in Field mode regardless Blink


(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
Set GS CRTC configuration. NTSC 640x448 @ 59.940 (59.82) Interlaced (FIELD)


(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
Set GS CRTC configuration. PAL  640x512 @ 50.000 (49.76) Interlaced (FIELD)


---------------------------------------------------------------------------------------------------------
(UpdateVSyncRate) Mode Changed to SDTV 480p.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
Set GS CRTC configuration. SDTV  720x480 @ 59.94 Progressive (FIELD)

(UpdateVSyncRate) Mode Changed to HDTV 720p.
(UpdateVSyncRate) FPS Limit Changed : 60.00 fps
Set GS CRTC configuration. HDTV  1280x720 @ ??.??? Progressive (FIELD)
---------------------------------------------------------------------------------------------------------
(UpdateVSyncRate) Mode Changed to HDTV 1080i.
Set GS CRTC configuration. HDTV 1920x1080 @ 60.00 Progressive (FIELD) <--- Correctly shows as Interlaced in the Title bar Blink
---------------------------------------------------------------------------------------------------------

576P still comes up as 480P Blink
(UpdateVSyncRate) Mode Changed to SDTV 480p.
Set GS CRTC configuration. SDTV  720x480 @ 59.94 Progressive (FIELD)
Reply

Sponsored links

#2
The Field/Frame setting doesn't matter when the signal isn't interlaced, the setting is ignored.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Ok but then why am I also seeing FRAME used by Interlaced games?
namely the ones that have those Deinterlace codes?
it even switches to Field for FMV playback, can't tell if the FMV is meant to be Progressive or 60fps,
doubt it's 60fps encoded because of the file size, the screenshot is from MPC-BE, PCSX2 title bar stays as Interlaced.

Set GS CRTC configuration. NTSC 640x448 @ 59.940 (59.82) Interlaced (FRAME) <-- Company logo introduction screens.
Set GS CRTC configuration. NTSC 640x448 @ 59.940 (59.82) Interlaced (FIELD) <-- FMV, MOVIE1UC.BIN
Set GS CRTC configuration. NTSC 640x448 @ 59.940 (59.82) Interlaced (FRAME) <-- Main Menu

   
Reply




Users browsing this thread: 1 Guest(s)