Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Haunting Ground glitch: Everything is green!
#1
Not sure if this is the right forum so please move it if necessary Blush

So I've been testing out Haunting Ground/Demento on PCSX2 and with some hardware fixes like TC Offset = 500 and the latest revisions, it's running great aside from some occasional blooming. Until I get to Daniella's level and then things start getting weird. This happens after I use the Saturnus key on the door to go to the mansion. In the room where Daniella screams at herself in the mirror, everything is green. As soon as I leave that room, though, it stops. It doesn't affect gameplay so I'm not too worried about it but it seriously looks like the Hulk exploded all over the screen.

[Image: 31614072.jpg]

[Image: hggreen1.jpg]

[Image: hggreen2.jpg]

I know Haunting Ground is a tough cookie and has been hacked a lot to get it working right but this is officially the weirdest glitch I have ever encountered in PCSX2 because I have absolutely no idea what would cause it. Why green? Why only one room? I don't understand! D:

I'm using GSdx 5570 and default specs except TC Offset = 500 which I mentioned earlier. Switching to software mode makes it look normal but it's suuuuper slow for me, like a 30 fps drop.

SPECS:
GeForce GTX 650
AMD FX™-6100 Six core processor 3.3 GHz
Reply

Sponsored links

#2
bump Tongue
Reply
#3
Wait...skipdraw = 500? Maybe I am just not understanding, but what happens when you lower it down to a more normal number like 1 or 2?...Does the green disappear? I have seen skipdraw do strange things in my games when the value gets too high.
Intel Core i5-8600K @ 4.5 GHz
GeForce GTX 1080 SC2 Stock
ASRock Z370 Taichi LGA 1151 mobo
CORSAIR Vengeance LPX 16GB 2400 DDR4 RAM
SAMSUNG 970 EVO M.2 2280 500GB PCIe SSD
Indigo Xtreme Thermal Interface Material
Phanteks Enthoo Pro ES614P Black Steel Case
EVGA SuperNOVA 750 G2 220-G2-0750-XR PSU
Windows 10 64-bit
Reply
#4
GAH I had a brain fart. I didn't mean skipdraw, I meant TC Offset. Sorry! D:

TC Offset set to 500 on both x and y helps a lot with the blur that is revealed when upscaling the resolution.

I tried everything I could think of to fix the weird green... checked all hardware hacks randomly, changed the core settings, changed to DX9, but no luck. I don't think the green was there when I tried the game on PCSX2 a few months ago. Must be with the new revision, but changing to an older revision is out of the question since the newer rev fixed a ton of old problems.
Reply
#5
Make note of all your settings, reset everything to defaults, then enable them one by one to try and find the culprit, Just a suggestion.
Reply
#6
Yeah, I tried all that Sad I don't remember this happening with an earlier revision of PCSX2 but the newer revisions already fix so much so uh... down...dating is out of the question.
Reply
#7
Try software mode,while in game press f9.also set extra rendering threads to 4 in video plugin settings before.
Reply
#8
(04-11-2013, 06:36 AM)Preet Wrote: Try software mode,while in game press f9.also set extra rendering threads to 4 in video plugin settings before.

Doesn't "software" mode usually slow don't things a lot though? maybe it is just with specific games, but when I had an issue with shadows in SB: BFBB I could use "software" mode to fix it. However though the shadows displayed properly I had gone from 59FPS-60FPS to around 21FPS.

Related: the shadow issue.
Reply
#9
(04-11-2013, 06:44 AM)Scootaloo Wrote: Doesn't "software" mode usually slow don't things a lot though? maybe it is just with specific games, but when I had an issue with shadows in SB: BFBB I could use "software" mode to fix it. However though the shadows displayed properly I had gone from 59FPS-60FPS to around 21FPS.

Related: the shadow issue.

i saw u have six core amd processor right? That's why i said that set extra endering threads to 4.it'll help u gain some speed in software mode.because it'll take advantage of u'r extra cores Smile
Reply
#10
(04-11-2013, 07:09 AM)Preet Wrote: i saw u have six core amd processor right? That's why i said that set extra endering threads to 4.it'll help u gain some speed in software mode.because it'll take advantage of u'r extra cores Smile

Six cores? lol I wish... I have a quad core (4 cores) actually. Even with the quad core software mode still runs very slow.
Reply




Users browsing this thread: 1 Guest(s)