Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help: Now that the new version is out, is God of War playable?
#1
I just tried it myself, and even with the recommended speedhacks enabled, and running at native PS2 resolution, my framerate drops to about 30-40 FPS as soon as enemies are shown. It seems like the game runs perfectly during cutscenes and other parts where there aren't any enemies.
My specs are:
i7 920 (not overclocked)
3 GB DDR3 RAM (triple channel)
GTX 460 1GB (I believe it is slightly overclocked)
Does anyone know what the best configuration settings are?
Reply

Sponsored links

#2
Something else at play here since GoW1 has been playable at full speed by people with lower specs for a good long while.
Reply
#3
I should probably add that I used to play Kingdom Hearts with an older version of the emulator, and it worked perfectly fine (even without any speedhacks). I gave up on trying to get God of War to work though, because it would always run slow. Maybe I just didn't use the right configuration though?
Reply
#4
put the speed hack on the highest setting (the hack does not cause any problem)
Reply
#5
Let's try just the recommended speedhacks first, k? Tongue2
Reply
#6
Now that 0.9.8 is out you can try enabling the "presets" slider, and testing each level on the slider (which activates speedhacks and other speed-up options Tongue2) until you find a good setting that doesn't break your game much.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
(05-02-2011, 04:25 AM)rama Wrote: Let's try just the recommended speedhacks first, k? Tongue2

instead of going down from up going up from down is a lot better.
Reply
#8
Orchlon: That is until they come back to the forum complaining that there game isn't working when they have every speed hack on minus one or two Tongue2

As Shadowlady said, that's what the new slider is for anyways.
Reply
#9
I tried the presets, and I tried enabling only the recommended speedhacks. I still don't get a smooth 60 FPS. It seems like the framerate drops as soon as enemies start appearing. If I have the preset set too high, I also get some texture glitches, and it still doesn't play smooth. I have taken screenshots of all of my settings, just in case something is set wrong and that is causing all of my problems. Can someone please look at these and tell me if there is anything set wrong?

Plugins used: http://i.imgur.com/drTzG.png
Video plugin settings: http://i.imgur.com/AOuog.jpg
Audio plugin settings: http://i.imgur.com/rkikG.jpg
Emulation settings (EE/IOP): http://i.imgur.com/Va3e8.png
VUs: http://i.imgur.com/561bn.png
GS: http://i.imgur.com/wXmC9.png
Speedhacks: http://i.imgur.com/a41c2.png


Reply
#10
Try using the SkipDraw Hack. It made my dbz bt 3 a lot smoother and faster. Well whats your EE percentage.As said above try speedhacks.
Check the Disable Framelimiting Option.
Reply




Users browsing this thread: 1 Guest(s)