Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help- Playing killzone with emulator
#1
^^ Im trying to play killzone for PS2 through an emulator on my pc. I am using the actual disc which is in very good shape but for some reason I am getting no audio at all for the game. Do I have to change a setting in the emulator when using a disc?
Reply

Sponsored links

#2
Well first of all it's best to make an ISO out of your disc for performance reasons. So start there.

Meanwhile post your SPU2-X settings.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
(12-09-2015, 11:22 PM)Blyss Sarania Wrote: Well first of all it's best to make an ISO out of your disc for performance reasons. So start there.

Meanwhile post your SPU2-X settings.

Ah ok thank you! I will look into how to do convert to an iso but I have a fairly powerful machine so maybe I will be fine playing the disc?. I havnt done much emulating I have the settings at whatever default setting they were at but heres a screen shot of the settings.


Attached Files Thumbnail(s)
   
Reply
#4
Download imgburn and make the ISO with that. It's incredibly easy, and won't need any explanation.

Also, change from port audio to Xaudio2 in your spu2x config.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#5
Now I am having issues with the game responding to input. I have a controller plugged in with all the keys mapped and it works when I test the controller in the settings menu but once I start the game it ignores controller input for some reason. I was playing a different game earlier and the controller was working fine..
I switched to Xaudio2 and now the sound is working but the game doesn't want to respond to input from the controller for some reason? I have had this same issue when I tried to emulate another game but the controller works when I test it in the configuration menu and worked fine when I emulated action replay. Sorry for the extra post
Reply
#6
You need to map your input controls.

Lilypad settings -> 2nd tabpage (pad1)
Reply
#7
(12-10-2015, 12:49 AM)willkuer Wrote: You need to map your input controls.

Lilypad settings -> 2nd tabpage (pad1)

No I already did that its mapped and works when I test it in the configuration menu but its not responding in game.
Reply
#8
Please post first two tabpages of lilypad settings.

Which control doesnt work? Normally games require pressing start in the beginning or some other confirmation.
Reply
#9
(12-10-2015, 12:56 AM)willkuer Wrote: Please post first two tabpages of lilypad settings.

Which control doesnt work? Normally games require pressing start in the beginning or some other confirmation.

I managed to get it working by switching keyboard api from windows messanging to direct input, before that none of the controls would respond for this game but strangely would work fine for other games. Now the controls are working fine and the cut scenes and audio worked great but when I get past the opening scene into actual game play the screen looks like this-V- If anyone has any ideas on how to fix this? I'm still in the process of converting the disc to an image iso but I don't see how that will help with the render issue.


Attached Files Thumbnail(s)
   
Reply
#10
press F9, or get latest git and use opengl mode. I think this kind of issue has been corrected in the latest gits
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)