Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(Help!) Silent Hill 2 FMV lag.
#1
Sort of new to using Pcsx so I'm a bit ignorant of things but I've tried essentially everything to get this to work and it just won't.
During the FMV's it usually studders and lags and the framerate goes to absolute *****. The actual gameplay seems to run perfect though.

I know you are supposed to switch between Hw and SW or just turn on the gamefix(switch to gdsx software when an fmv plays).

I've been playing with the settings testing things out on the fmv that plays when you sit on the title screen for a minute. I'll go back to the title screen and then usually once the fmv plays the second time it will work perfect UP TO the point that i quit playing it and then it will start lagging again but this doesn't happen every-time. Seeing it work fine like that makes me think its fixable somehow.


I really have no idea what gdsx setting are supposed to be. 
Adapter: Currenty have it default hardware device
Renderer: Direct3D9 Software

Basically any of the settings on gdsx settings I'm not really sure what to set them at.

i am using a gaming laptop.
I have windows 10, i7-6700HQ CPU 2.6
And Geforece 960M Graphics 8 gigs ram


Any suggestions? I'm pretty much ready to give up I've been messing with this for over 6 hours.
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Use OpenGL Hardware for best results, but since you're on a laptop, it will probably lag quite a bit on 4x native res and above. As for the FMVs, they should play at full speed if you toggle software mode on (or use the fix). Make sure your PCSX2 version is at least 1.4.0. You might wanna download some 1.5.0 builds and test the game out on those, see if performance improves.
Reply
#4
The issue with the FMV (.bik videos) described in the first post still persists.

It only happens on PAL builds of the game: SLES-50382 (SILENT_HILL_2__VW047E1) and SLES-51156 (SILENT_HILL_2_DCUT_EU__102).
When the game loads up an FMV cutscene, one of the two scenarios happen:

1. A cutscene loads up properly, with no black screen delay. FPS maintains at 50 flat during the cutscene;
2. A cutscene loads up with 3-5 seconds delay (black screen is shown, music continues to play), FPS drops to 30-35 and stays on this level throughout the entire cutscene.

I've tested both PAL builds on the official PCSX2 1.4.0 release and pcsx2-v1.5.0-dev-2699-g9899d0d6b-windows-x86 build.
Automatic Gamefixes and Switch to GSdx software rendering were on.
The bug happens on both of them.

https://youtu.be/mdXifcrCevU

In this video I use a savestate made prior to one of the FMV cutscenes. You can see that it loaded up properly on the first try, on the second try it rendered a black screen delay I've described above, and on the third try the game outright refused to show the FMV.
Reply
#5
What if you don't run with Automatic Gamefixes enabled ?
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#6
(11-27-2018, 02:58 PM)lightningterror Wrote: What if you don't run with Automatic Gamefixes enabled ?

No change. The bug keeps happening.
Reply




Users browsing this thread: 1 Guest(s)