Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help with low frame rate
#1
Video 
Hi guys! So I've been using PCSX2 for awhile now, and I've gotten Ratchet Gladiator(Or Deadlocked if not in EU) to run normal speed, without a slow down (EE reads below 100%, GS and VU also nowhere near max). I've got the game 100% speed, registering 50.07-49.96FPS in the window, however, I can certainly notice that the game itself isn't giving me a smooth frame rate, I'd hazard a guess it drops as low as 22, but otherwise looks to run at 24-26? The game is still very playable, and it's a non major issue, I'm just wondering if there's a fix?

Macbook: Bootcamp Windows 10 Home
Intel Core i7-4870HQ
AMD Radeon R9 M370X
PCSX2 v1.5.0-dev-2421

(Averages when running the game)
EE: 46%
GS: 16%
VU 7%

Direct X11 [Hardware]
2x Native Resolution
Anisotropic 16x

EE Cyclerate -3
INTC Spin Detection - True
Wait Loop Detection - True

VU Cycle Stealing 0
mVU Flag Hack - True
MTVU - True

My guess is that the cyclerate being -3 has some effect on this...
Reply

Sponsored links

#2
I've just started playing my Ratchet Gladiator - definitely sounds cooler than Deadlocked - on Pcsx2 and my specs are slightly worse than yours and I'm still running at +58 fps so you should definitely be able too.

These are my settings :

Native Resolution
Anisotropic Off

EE Cyclerate +2
INTC Spin Detection - True
Wait Loop Detection - True

VU Cycle Stealing +2
mVU Flag Hack - True
MTVU - True

You'll probably run the game just fine with this, then you can try changing by the resolution and/or anisotropic to your old settings to see if those were the issue.
Oh, just in case your Radeon isn't your default GPU, make sure to have it as your adapter in the Gsdx settings.

What I'm surprised about is you're absolutely not having the issue that had me struggling all day. When using Direct3D11 I have red lines across my screen whenever I'm on an open area. ( When in the battle dome, It looks good but on a planet, i get the red lines ) I had to switch to Open GL and stuff.
Perhaps that's because your game is Ratchet Gladiator and mine is Ratchet Deadlocked.
Reply
#3
(06-29-2018, 07:59 PM)Snow Breath Wrote: I've just started playing my Ratchet Gladiator - definitely sounds cooler than Deadlocked - on Pcsx2 and my specs are slightly worse than yours and I'm still running at +58 fps so you should definitely be able too.

These are my settings :

Native Resolution
Anisotropic Off

EE Cyclerate +2
INTC Spin Detection - True
Wait Loop Detection - True

VU Cycle Stealing +2
mVU Flag Hack - True
MTVU - True

You'll probably run the game just fine with this, then you can try changing by the resolution and/or anisotropic to your old settings to see if those were the issue.
Oh, just in case your Radeon isn't your default GPU, make sure to have it as your adapter in the Gsdx settings.

What I'm surprised about is you're absolutely not having the issue that had me struggling all day. When using Direct3D11 I have red lines across my screen whenever I'm on an open area. ( When in the battle dome, It looks good but on a planet, i get the red lines ) I had to switch to Open GL and stuff.
Perhaps that's because your game is Ratchet Gladiator and mine is Ratchet Deadlocked.
I’ll give these settings a go and get back to you Smile cheers for the suggestions!


For your texture issues, I put mipmapping on and it fixed it. Hope this helps!
P.s I have no clue why they called the same game different names. Was always confused looking this game up on google when all items seemed to relate to deadlocked ?
Reply
#4
Hope it works !

Isn't mipmapping a software-only setting? It is in my case so I had to switch to Direct3D11 Software to use it - it was on by default - and it actually works just fine, I just had to switch to software, why did I assume it wouldn't work? ._.

No idea why their names are different either, I only have Deadlocked but I played Gladiator too - the most, actually - and they're the same. Even the unlock codes are the same so I have no clue.
Reply
#5
mipmapping is software only on 1.4.0 or older and part of hardware (directX 11 and OpenGl) on 1.5.0 and above. So just update to one of the Dev builds to get it
Reply
#6
Oh, you're right, thanks.
Reply
#7
Edit : Nevermind
Reply
#8
Just tried your settings, I was getting the same problem but with a worse "actual" frame rate. The game ran at 100% as usual and showed 50FPS but there was noticeable visual stuttering. I think after giving those settings a try, and messing around with EE Cyclerate more, that my drop in "actual" frames is a direct result of having my EE cyclerate be something other than 0

On your texture issue, in my PCSX2 (v1.5.0-dev-2421), under Config --> Video (GS) --> Plugin settings, on the hardware settings, there should be a mipmapping setting in a dropdown menu just above the CRC Hack level. I have both mipmapping and CRC hack level set to Automatic
Reply
#9
Yeah, I got that, all good. Your visual lag seems different from mine because, just like you, I have 100% , good fps but some visual lag, but that's only when my EE Cyclerate is negative, as soon it goes from 0 to +3, the visual stuttering just goes away.
Reply
#10
The entire Ratchet and Clank series is one of the finer cases of PS2 games with a variable internal frame rate.

If the EE GS and VU utilization numbers are under 100%, that is actually good, that means you have some room before your PC CPU gets bogged down and grinds to a halt.

Since you're playing the EU release (btw, Insomniac made it a point to change EU release names from the rest of the world, probably cause the EU didn't take a liking to the innuendos that they made every other title in the series) 50 FPS means you are at full speed, since that's the PAL standard.

If your internal frame rate is diving but the game still running full speed, this is technically normal behavior, but also fixable. Simply turn the EE cyclerate up, and the internal frame rate will go up. This will need a more powerful CPU, but from what I've read I think you have some power to spare. A fair warning, a few points in each Ratchet and Clank game may hang up if running a non default cyclerate. Typically it is when loading into a new world, so if auto save is on, no data loss, just means you gotta reboot the game on default cyclerate.

Also, don't use VU cycle stealing, this generally works counter to what you're actually trying to do, helping a small number of games with VU timing problems run at full speed, at the expense of internal FPS. The Ratchet and Clank series is not a proven case for this.

An edit since textures were mentioned:
Mipmapping is available on OpenGL HW starting with the 1.5 dev builds. This will fix a ton of texture problems and should kick on automatically when needed, if you don't change the setting. But the Ratchet and Clank series has a problem with depth emulation, so you will need to disable that in the advanced hacks section or you may get the fun "everything on the map except some silhouettes disappeared" problem.

Also added a note about the hangup issue for the cyclerate.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply




Users browsing this thread: 1 Guest(s)