"Hide DS4 controller" option problems
I have been using DS4 tool for a while now with no problems whatsoever, but I recently tried to get my controller to work on Dragon Age Inquisition and have not been able to do so. When I don't use "hide DS4 controller" all the buttons are messed up, and when I do use it the controller just doesn't show up. I haven't been able to find a solution from searching around yet, either.

Sponsored links

To my knowledge the "hide DS4" option should disable the native support for DS4 controllers so that only the XInput wrapper works and you get an XInput controller.

I would guess you made some error in the xinput wrapper configuration so that the xinput controller is not recognized correctly. I think you should keep that option active and try to solve the xinput problem.

Can you check what is written in the windows controller/gamepad configuration?
You mean the configuration in DS4 tool or what? I've always had "hide DS4" work in the past.
Which tool do you use?

I think the problem is in the tool. Or better in your configuration of the tool.

You can check if it works in the windows controller configuration. Which might look similar to this:

[Image: Untitled-1-5.jpg]
DS4 to XInput Mapper 1.2.2 but I have also tried DS4windows and that had the same issue
[Image: 19e365c85e03fc274d8fa25590da6ee1.png]
[Image: c62bf8d622ef6cee4af69be91053b29a.png]
Here is what it shows for me. The first is with hide DS4 checked and the second is without
I would still suggest to use the fork of Jay2Kings or jhebbel. I think the old version you use is not supported anymore.

If you decided which of the wrappers you want to use I would suggest you post directly in their thread and ask for support. These threads are more often read by their owners as well as experiences users.

I think a clean reinstall should solve your problem but maybe that is not even needed. Unfortunately I can not help you much further than what I already said.

Yes I think your picture is confirming what I was guessing. You don't see the Xinput device and this should be the problem. If you disable "hide DS4" you get some not working wireless driver.

Look as well in the video InhexSTER posted. I think you see a similar picture.

Users browsing this thread: 1 Guest(s)