Horizontal Lines in some games
#1
Im experiencing horizontal lines in certain games despite being in software mode. Not sure what im doing wrong i have the emulator set to safe mode and I have the hardware to run any game on ultra high settings.

ps. Not sure why i cant post a screenshot
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#3
(10-02-2019, 08:09 PM)jesalvein Wrote: Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
my Rig
CPU: Intel I-7 9700k
Graphics Card: RTX 2080 8GB 
Memory: Corsair Vengeance LPX 16GB 3200 mhz

[code] PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 18362), 64-bit
Physical RAM    =  16315 MB
CPU name        =  Intel® Core™ i7-9700K CPU @ 3.60GHz
Vendor/Model    =  GenuineIntel (stepping 0C)
CPU speed        =  3.599 ghz (8 logical threads)
x86PType        =  Standard OEM
x86Flags        =  bfebfbff 7ffafbff
x86EFlags        =  2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
Binding  GS: E:\LaunchBox\Emulators\PCSX2 1.4.0\plugins\gsdx32-avx.dll
Windows 10.0.18362
Binding  PAD: E:\LaunchBox\Emulators\PCSX2 1.4.0\plugins\lilypad.dll
Binding SPU2: E:\LaunchBox\Emulators\PCSX2 1.4.0\plugins\spu2-x.dll
Binding CDVD: E:\LaunchBox\Emulators\PCSX2 1.4.0\plugins\cdvdGigaherz.dll
Binding  USB: E:\LaunchBox\Emulators\PCSX2 1.4.0\plugins\USBnull.dll
Binding  FW: E:\LaunchBox\Emulators\PCSX2 1.4.0\plugins\FWnull.dll
Binding DEV9: E:\LaunchBox\Emulators\PCSX2 1.4.0\plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9693 games on record (loaded in 114ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 10.0.18362
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Current Renderer: Direct3D9 (Software mode)
NVIDIA GeForce RTX 2080 (26.21.14.3630)
Opening SPU2
Opening CDVD
isoFile open ok: E:\LaunchBox\Games\Sony Playstation 2\Legacy of Kain - Defiance (USA)\Legacy of Kain - Defiance (USA).iso
Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2122304 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0 [File]: E:\LaunchBox\Emulators\PCSX2 1.4.0\memcards\Mcd001.ps2
McdSlot 1 [File]: E:\LaunchBox\Emulators\PCSX2 1.4.0\memcards\Mcd002.ps2
McdSlot 2 [File]: [is not memcard file]
McdSlot 3 [File]: [is not memcard file]
McdSlot 4 [File]: [is not memcard file]
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA    v01.60(07/02/2002)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.63, ctm:392Mhz, cpuclk:294Mhz detected)

PlayStation 2 ======== Hard reset boot
ROMGEN=2002-0207, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
<20020207-164243,ROMconf,PS20160AC20020207.bin:11552>
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb  7 2002 16:41:20
  CPUID=2e20, BoardID=0, ROMGEN=2002-0207, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_207.73;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_207.73;1) Game CRC = 0x728AB07C, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_207.73;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 © Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLUS_207.73;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLUS_207.73;1
0 00100000 0018ee70 .........................
Loaded, cdrom0:¥SLUS_207.73;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 © Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
_gp        :  294af0 (2706160)
_stack      :  1ff8000 (33521664)
_stack_size :    8000 (32768)
_end        :  1fef2d8 (33485528)
_heap_size  : ffffffff (-1)
ENTRYPOINT  :  100008 (1048584)
_start      :  100008 (1048584)
_fbss      :  28ee80 (2682496)
FIN_BUILD
GM_BUILD
USE_BIGFILE
USE_CD
loadmodule: fname cdrom0:¥MODULES¥SIO2MAN.IRX;1 args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥MODULES¥DBCMAN.IRX;1 args 0 arg
loadmodule: id 26, ret 0
loadmodule: fname cdrom0:¥MODULES¥SIO2D.IRX;1 args 0 arg
loadmodule: id 27, ret 0
loadmodule: fname cdrom0:¥MODULES¥DS2U.IRX;1 args 0 arg
loadmodule: id 28, ret 0
loadmodule: fname cdrom0:¥MODULES¥DS2U.IRX;1 args 0 arg
loadmodule: id 29, ret 0
loadmodule: fname cdrom0:¥MODULES¥LIBSD.IRX;1 args 0 arg
loadmodule: id 30, ret 0
loadmodule: fname cdrom0:¥MODULES¥SDRDRV.IRX;1 args 0 arg
SDR driver version 4.0.1 © SCEI
Exit rsd_main
loadmodule: id 31, ret 0
loadmodule: fname cdrom0:¥MODULES¥IMEMMAN.IRX;1 args 0 arg
IMEMMAN init
IMEMMAN: set rpc queue
IMEMMAN: register function
IMEMMAN: allocate 6 meg for 2 meg simulation
IMEMMAN: goto wait loop 1657856 free mem
loadmodule: id 32, ret 0
loadmodule: fname cdrom0:¥MODULES¥ISNDSTRM.IRX;1 args 0 arg
IOPSNDSTRM: Setting up RPC-queue
IOPSNDSTRM: Register function
loadmodule: id 33, ret 0
loadmodule: fname cdrom0:¥MODULES¥CDLOADER.IRX;1 args 0 arg
IOPLOAD: RPC Initialize
IOPLOAD: set rpc queue
IOPLOAD: register function
IOPLOAD: goto wait loop
loadmodule: id 34, ret 0
loadmodule: fname cdrom0:¥MODULES¥MCMAN.IRX;1 args 0 arg
loadmodule: id 35, ret 2
loadmodule: fname cdrom0:¥MODULES¥MCSERV.IRX;1 args 0 arg
loadmodule: id 36, ret 2
loadmodule: fname cdrom0:¥MODULES¥IOPSND.IRX;1 args 0 arg
IOPSND init
IOPSND: init libsd
IOPSND: Clearing 0x5000 SPU block!
WARNING: WaitEventFlag KE_CAN_NOT_WAIT
loadmodule: id 37, ret 0
IOPSND: set rpc queue
IOPSND: register function
IOPSND: goto wait loop
args <shold 1
>
****SND Sound driver initialisation****
Initialising libsdr...
SNDIOP binding finished!
****SND Sound driver initialisation done****
SNDSTRMIOP binding finished!
ps2/shellMpeg/shellMpeg.c(1334) : End of stream presumed
ps2/shellMpeg/shellMpeg.c(1334) : End of stream presumed
IPU1 Normal error!
Reply
#4
1 - why are you using D3d9 with that GPU ?
2 - better use latest git build
3 - what kind of line are you talking about ? any screenshot ? make sure you post it on a pic hosting site like imgur
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#5
(10-02-2019, 09:04 PM)jesalvein Wrote: 1 - why are you using D3d9 with that GPU ?
2 - better use latest git build
3 - what kind of line are you talking about ? any screenshot ? make sure you post it on a pic hosting site like imgur

Thats just the last setting I tried I tried them all starting with D3d11 Hardware, D3d9 Hardware, D3d9 Software, and D3d11 Software but im getting the same problem on a couple of games no matter what settings ive changed.

Here is a screenshot of the issue.
https://screenshot.net/91607td
Reply
#6
DX9 is selected by default on 1.4.0
Switch to OpenGL
https://buildbot.orphis.net/pcsx2/
Reply
#7
^ this
and use latest git build
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply




Users browsing this thread: 2 Guest(s)