How do I disable Vsync?
I'm having some issues with input delay, and I've tried looking online about how to possibly remove this delay and I commonly see people mentioning disabling Vsync. 

I've tried disabling 'Wait for Vsync on refresh' in the Window Settings (and in fact, it's disabled by default...) and noticed no change, and so I began wondering if there was another Vsync option somewhere else that I'm missing. The game is always running at 100% so I wouldn't pin it on my PC's specs or the game running slowly. 

The delay itself is roughly a 1/4 of a second. It's managable and I can live with it, but if I can remove it then I'd rather remove it. I'm using a wired 360 controller.

I can post any information about the specifications of my PC or the current plugins and plugins settings if needed at request. Any help is much appreciated.

Sponsored links

I was wondering about this whole Vsync thing myself. Is there any way to run the game at a much higher frame rate than 60fps, but retain the proper speed and motion of the game?
In PCSX2, you can change vsync via config -> emulation settings -> gs window (if presets are enabled then it'd be grayed out and disabled).

On windows 8 or later you can't really disable vsync since the whole desktop has vsync, and PCSX2 doesn't support non-window full screen (where vsync can really be disabled).

In general it's not possible to make the emulation produce higher fps than the game originally has but still run at the same game speed, but some specific games have 60fps hacks/cheats which you can find and use (I think kingdom hearts is one of those).

It's also possible to use speed hacks which _might_ do what you want - at config -> emulation settings -> speedhacks, try to start with preset 1 or 2, then disable presets and increase the value of EE cyclerate (move the slider to the right).

Note that both the 60fps patches and the speedhacks options require a significantly fast CPU to pull off.

Users browsing this thread: 4 Guest(s)