Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How do I make 2 pads binded to a single keyboard?
#1
Hello, decided to register here because I was desperate for help.

I wanted to play a local co-op multiplayer game, and I have trouble connecting an actual PS2 controller to my computer. Besides, I considered sharing one keyboard is much better than playing with a controller. It doesn't seem worth it to connect a controller just to play with a controller when few buttons are ever needed.
So I bind both Pad 1 and Pad 2 to my keyboard, where player 1 has the left and player 2 has the right. Controls do not overlap. Is it possible that only one player can have the keyboard and others besides Pad 1 need to use controllers?
Reply

Sponsored links

#2
You could even use one keyboard for all 8 players if you really wanted to, but keyboards have a limited number of key presses that can be detected at the same time. The exact number differs per keyboard.
Reply
#3
(01-31-2018, 01:12 PM)FlatOut Wrote: You could even use one keyboard for all 8 players if you really wanted to, but keyboards have a limited number of key presses that can be detected at the same time. The exact number differs per keyboard.

So you are saying it is possible to bind both pads 1 and 2 to a single keyboard? This doesn't seem to work for me. I can bind keys on pad 1 and it works perfectly fine. But pad 2 doesn't seem to do anything when I press a key bound to pad 2. Am I doing something wrong? Keyboard API is left on Windows messaging and port 1 and 2 multitap are checked.
Reply
#4
(01-31-2018, 05:26 PM)ThatTEEN14 Wrote: So you are saying it is possible to bind both pads 1 and 2 to a single keyboard? This doesn't seem to work for me. I can bind keys on pad 1 and it works perfectly fine. But pad 2 doesn't seem to do anything when I press a key bound to pad 2. Am I doing something wrong? Keyboard API is left on Windows messaging and port 1 and 2 multitap are checked.
If you enabled multitap you need to set the controls of player 2 to Pad 2A unless the game you're playing is a multitap title.
Reply
#5
(01-31-2018, 05:38 PM)FlatOut Wrote: If you enabled multitap you need to set the controls of player 2 to Pad 2A unless the game you're playing is a multitap title.
That's what I did. Player 2's controls are on pad 2A, but pressing anything assigned to 2A doesn't do anything. would it help to tell what game I am testing?
Reply
#6
(01-31-2018, 05:46 PM)ThatTEEN14 Wrote: That's what I did. Player 2's controls are on pad 2A, but pressing anything assigned to 2A doesn't do anything. would it help to tell what game I am testing?
Yes, the game and the PCSX2 version you're using would help.
Reply
#7
Oh hey! I got it to work! I did it! I don't know what I did wrong before but I got it to work. Thanks for your help, appreciate it. Smile
Reply




Users browsing this thread: 1 Guest(s)