Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to change search path for drivers in GSdx
#1
Hey everyone, I'm having a bit of a problem loading a game in PCSX2 and I'm pretty sure it's because of the GSdx plugin. I get the following output in the console:


Code:
libGL error: MESA-LOADER: failed to open radeonsi (search paths /usr/lib32/xorg/modules/drivers)
libGL error: failed to load driver: radeonsi
libGL error: failed to open /dev/dri/card0: Permission denied
libGL error: failed to load driver: radeonsi
libGL error: MESA-LOADER: failed to open swrast (search paths /usr/lib32/xorg/modules/drivers)
libGL error: failed to load driver: swrast
Failed to create the opengl context. Check your drivers support openGL 3.3. Hint: opensource drivers don't

I verified my drivers support OpenGL 3.3 (they support OpenGL 4.5 according to glxinfo)
I'm pretty sure the issue lies in the fact that /usr/lib32/xorg/modules/drivers doesn't exist on my system, but /usr/lib/xorg/modules/drivers does exist and that's where my radeonsi and swrast drivers are located (as x86-64). I do have allĀ  the 32 bit mesa drivers installed on my system. I poked around the GSdx plugin settings but I couldn't find a setting to change the search path for drivers.

I am using Void Linux, with an AMD RX 580 gpu. Thanks!
Reply

Sponsored links





Users browsing this thread: 1 Guest(s)