How to get a Retrolink SNES Controller working with PCSX2 1.7.3917/macOS
I'm running PCSX2 nightly 1.7.3917 on an Intel-based macOS Catalina 10.15.7 laptop and I'm looking to get the "SDL-0: Retrolink SNES Controller" (USB) working. As can be seen through the first attachment, PCSX2 is correctly detecting the USB controller by name. However, no controller buttons appear to have any effect. It's as though it's not attached. And I'm left with keyboard-based controls, which work.

Quite some time ago, on another system (not macOS; this time, a Linux installation) I found that the controller worked just fine and was automatically detected. However, here I find "DualShock 2" under "Controller Port 1" whether or not I have the USB Retrolink connected and so to me this looks like some generic setting not applicable to my controller. Also, the "USB Port 1" (and 2) both show as "Not Connected", whether or not I have the USB Retrolink connected. And then the options for the "Device Type" dropdown show a lot of very different potential devices unrelated to a controller. Also that's confusing because PCSX2 correctly shows when the Retrolink is attached, so this looks like some ability to auto-detect (though it may just be reading the USB information that comes by default with all devices added to the bus, rather than properly seeing the device as a controller). I also have Checked: Enable SDL Input Source.

Basically, I haven't altered any settings and this is a base configuration. If automatic detection isn't possible or working here, I'm wondering what my options are. Is there some manual setup that I can perform? Are there logs I can find which might clarify what's going on? Is it possible that this controller may not work on macOS at all, though it was working fine in another environment? Or is my use of nightly causing an issue? (I saw some earlier release from last April, but I would have assumed it's relatively out of date and that mainly improvements have happened since then.)

The second picture attached showcases what I see under the controller settings section. Whether or not that section is applicable to my situation, this picture also shows that the "USB Port 1" (and 2) are showing as Not Connected. As noted above, the first picture confirms that the USB device is at least seen by PCSX2.


Sponsored links

I'm answering my own question here, in case it helps others. I didn't notice at first the "Automatic Mapping" on the right was a drop-down that included options such as my attached USB controller. Even though this was under the Controller Port I / DualShock 2 (and I don't quite know what the latter means), nevertheless, once I did the automatic mapping, the buttons then worked, plus I can likely tweak the assignments to satisfaction.

Users browsing this thread: 1 Guest(s)