How to make Soul Calibur 2 work for those that get the DMA error.
Instead of loading it from an ISO, mount the ISO and use the CDVDolio plugin and use Run CD/DVD. Bye bye DMA error.

Aside from the screen being jittery in battles always (no matter what Interlacing you use) and a certain graphical glitch where theres some sort of transparent shadow covering the screen (doesn't happen always, depend on the stage I think), it works fine.

This was tested on r1736 (latest officially released beta) and using GSDX 1763.

Someone else try it with different graphic plugins and post if the graphic glitches are gone.

Hope this helps.

Sponsored links

at first i was happy to have found someone who really seems to provide a solution to this error - i tried google and all i found was just closed posts from people trying to run an illegal copy of the game - but your way doesn't help either

i used the CDVDolio plugin with PCSX 0.9.6 & the DVD in the drive and STILL get the DMA error :-(

maybe i might have got an outdated version of CDVDolio - can you tell me where to get the newest compiled versions (authors page or something ?)

is there any other setting i need to be aware of ? by now i'm running on the standart PCSXE settings it came with + GSDX 890 / SSE3 / DX10 hardware + SPU2-X 1.1.0

thanks in advance

oh - and to iron out any misunderstandings right from the start and keep this thread from being closed as well - i DO own the game (german PAL version) and i DO own a PS2 ;-)
Umino: Have you tried the latest beta (1888) from the download section? Try that and the latest plugins in that package and see if you still get that error.
[Image: 2748844.png]
beta 1888 of PCSXE i guess - no i have not - but i might give it a try this week

the funny thing is - i just found a soulcalibur 2 save on one of my emus memory cards from 2008 so it MUST have worked on some earlier release (i think 0.9.4 or something) - i just don't remember wich plugins i used and if it's still included in the latest release because i deleted everything prior to 0.9.6

emulators are a funny thing - you add functions and get some stuff fixed just to break others again :-)

like with this sega saturn emulator - i had 0.9 and it worked - tried 0.10beta and it worked - with 0.11 they added deinterlacing - nice picture now but i get NO SOUND anymore at all no matter what settings i try - but that's off topic

edit: holy crap - i need DX 11 to run 1888 beta ?? and that DX installer is like 100mb - ok i'm going to bed - with my slow line it will take until tomorrow anyway
I don't know if using a physical cd works. I mounted the ISO on a virtual drive and that got rid of it.
Umino: No, it doesn't require DX 11... it does however require an up to date version of directX 9 and 10.
[Image: 2748844.png]
when i tried to launch r1888 there just popped off a message saying dx11something.dll is missing - anyway i got THAT one fixed by now

(11-01-2009, 09:12 PM)demoneva Wrote: I don't know if using a physical cd works. I mounted the ISO on a virtual drive and that got rid of it.

wich CDVD plugin do you use ?

i tried

PEOPS and Gigaherz - both running it straight from disc and daemon tools virtual drive.

also tried Linuz Iso plugin

all with the same results

and i tried some versions of CDVDolio but ended up with the same DMA error all the time

the latest release might be CDVDolio-r1894-vc10 - but it keeps telling me some .dll is missing wich is part of visual C runtime - i got VC runtime 2008 installed but i don't find any redist of a runtime newer than that - i found out that visual studio 2010beta brings the latest runtimes with it but where can i find JUST the runtimes?

oh and by the way - the r1888 release kicks ass - it didn't help me on soul calibur II yet but it DID speed up some other games wich where running up to 10 frames slower on the 0.9.6 - and i didn't even start to enable any speed hacks - if they keep that speed of progress - PCSX2 will SOON be about as good for PS2 emulation as ePSXe is for PS1 emulation by now

i remember when i first ran into PCSX2 - my PS2 was broken and i got code veronica and wanted to play it BADLY so i gave that emulator a try on my Athlon 64 3200 with 1gb of RAM and i was like "WHAAAAAT ??? 10 frames ?
is that all you got?" one or two releases later it was running full speed on the very same machine (but most of my other games were still broken back then)

edit: AYAYAYAAY !!!!! i got it i got it

this is what i did: chose linuz iso plugin but instead of loading the image file from the plugin config window - wich always gave me the DMA error on "execute" - i went to FILE -> Run iso image

it's THAT simple - an i was yanking and wanking around with plugins and whatnot

didn't notice they added a "run iso" command in the file menu because i never used to start a game via the file menu - i always took the run -> execute way because that way prooved to be more compatible somewhen

and the best thing is - it runs at playable speeds now (30-45 fps) - i remember soul calibur II and III running at horrible speeds on earlier releases

Users browsing this thread: 1 Guest(s)