Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to use latest (merged dev9) PCSX2 for Outbreak obsrv.org servers?
#1
edit: solved, made a guide on the Outbreak server forums.

https://obsrv.org/viewtopic.php?f=13&t=5816
Reply

Sponsored links

#2
Make sure you are using latest pcsx2 dev build. If you changed the DNS server in network settings that should be enough.
Reply
#3
(03-13-2021, 07:21 AM)prafull Wrote: Make sure you are using latest pcsx2 dev build. If you changed the DNS server in network settings that should be enough.

This is with latest build as of today. I can get past initial connection but it fails on DNAS.

Here is a Yandex translation of my PS2 network settings: https://imgur.com/a/uWfM4jt
DNAS failure, last image is the 1st test which passes: https://imgur.com/a/d7ATJ3V
PCSX2 settings: https://imgur.com/a/PBQQWZ8


Still doesn't work. In the old DEV9 plugin, there were more manual IP changes possbile in INI. Don't think I can get past DNAS error without more control? Example:

Code:
ConfigHost>
            <Desc>Set DNS to 192.0.2.1 to use this host list</Desc>
            <Enabled>false</Enabled>
            <IP>0.0.0.0</IP>
            <URL>www.example.com</URL>
        </ConfigHost>
        <ConfigHost>
            <Desc>Outbreak Login</Desc>
            <Enabled>true</Enabled>
            <IP>173.198.207.99</IP>
            <URL>www01.kddi-mmbb.jp</URL>
        </ConfigHost>
        <ConfigHost>
            <Desc>Outbreak Lobby</Desc>
            <Enabled>true</Enabled>
            <IP>173.198.207.99</IP>
            <URL>kddi-mmbb.jp</URL>
        </ConfigHost>
        <ConfigHost>
            <Desc>Outbreak DNAS</Desc>
            <Enabled>true</Enabled>
            <IP>153.121.44.150</IP>
            <URL>gate1.jp.dnas.playstation.org</URL>
        </ConfigHost>
    </Hosts>
    <SocketConnectionSettings>
        <AutoDNS1>false</AutoDNS1>
        <AutoDNS2>false</AutoDNS2>
        <DNS1>192.0.2.1</DNS1>
        <DNS2>192.0.2.1</DNS2>
        <IncomingPorts />
        <LANMode>true</LANMode>
    </SocketConnectionSettings>
</Config>
Reply
#4
It will start working again when this is merged.

https://github.com/PCSX2/pcsx2/pull/4220
Reply
#5
(03-13-2021, 11:49 AM)prafull Wrote: It will start working again when this is merged.

https://github.com/PCSX2/pcsx2/pull/4220

Thanks, for now I got it working with Npcap.
Reply




Users browsing this thread: 1 Guest(s)