Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to use shaders?
#1
Sad 
I read all the documentation about how to use shaders but I still have some doubts (I'm on PCSX 1.4.0, which should be the newest release):


-Do you still have to call them "shader.fx" or can you use their proper name?
-Do they still have to be in the "shaders" folder? If yes, can they be in a subfolder of "shaders"?
-Most shaders don't have a config.ini, but PCSX2 requires it. What should I do, point to a blank text file?
-Does the config have to have a special name like "shaders.ini" or it can be named freely?

I'm asking all this because I cannot make any shader work, and the HOME key (which should enable/disable them) doesn't do anything.



Currently I'm trying the GSdx FX Suite v2.30: both the "shader.fx", and the "GSdx_FX_Settings.ini" files are in the "shaders" folder, I configured the "GSdx_FX_Settings.ini" with a text editor but I cannot see any change in the picture.

Thanks in advance in case you decide to help me.

Sponsored links

#2
You need to select that shader in Config --> Video (GS) --> Plugin settings --> Shader Configuration --> External Shader.

Path is for pcsx2 1.5.0, but i think it was the same in 1.4.
#3
(09-24-2019, 07:56 PM)kozarovv Wrote: You need to select that shader in  Config --> Video (GS) --> Plugin settings --> Shader Configuration --> External Shader.


I know that, but they still don't work, do I have to use OpenGL? Currently I'm using Directx11 (Hardware), here's a screenshot of my configuration:

[Image: cCTLS7H.png]


P.S. isn't 1.5 unstable? The last "legit" version in the download section is the 1.4
#4
The last "legit" version is also 3 years old and honestly with all the bug fixes in the developer builds is probably less stable. If you are really worried about stability then you can do what I do. Whenever you start a new long game (RPG, something that takes a long time to complete) make a new folder for a git build and don't update that one until you complete the game. Keep a separate version as up to date as you are bothered to do, so you have the latest bug fixes and play your pickup and play games on that one. Regular in game saves should be pretty compatible across different versions. ( I would not do this with savestates, and you should never rely on savestates if you can avoid it since in all emulation they are a far more risky main save)

https://buildbot.orphis.net/pcsx2/index.php?m=fulllist

I am sorry that I can not really help with the shaders though. I have never used them or looked in to what kinds of shaders are even available.
#5
(09-25-2019, 05:23 AM)TkSilver Wrote: The last "legit" version is also 3 years old and honestly with all the bug fixes in the developer builds is probably less stable.  If you are really worried about stability then you can do what I do.  Whenever you start a new long game (RPG, something that takes a long time to complete) make a new folder for a git build and don't update that one until you complete the game.  Keep a separate version as up to date as you are bothered to do, so you have the latest bug fixes and play your pickup and play games on that one.  Regular in game saves should be pretty compatible across different versions.  ( I would not do this with savestates, and you should never rely on savestates if you can avoid it since in all emulation they are a far more risky main save)

https://buildbot.orphis.net/pcsx2/index.php?m=fulllist

I am sorry that I can not really help with the shaders though.  I have never used them or looked in to what kinds of shaders are even available.


Then why 1.4 is the last one available in the download section? Newbies like me are confused by stuff like that.
I'll do as you suggest for the savegames, and I hope someone can help with the shaders.



UPDATE - I checked the PCSX2 status window as the game was booting and I got this:
C:\Users\XXXXXX\Documents\PCSX2\shaders\GSdx.fx(26,1-6): error X3000: unrecognized identifier 'define'
GSdx: failed to compile external post-processing shader.

What does it mean?
#6
(09-24-2019, 06:12 PM)Mitsukuni Mito Wrote: Eu li toda a documentação sobre como usar shaders mas ainda tenho algumas dúvidas (estou no PCSX 1.4.0, que deve ser a versão mais recente):


-Você ainda tem que chamá-los de "shader.fx" ou você pode usar o nome próprio?
- Eles ainda precisam estar na pasta "shaders"? Em caso afirmativo, eles podem estar em uma subpasta de "shaders"?
-A maioria dos sombreadores não tem um config.ini, mas o PCSX2 exige. O que devo fazer, apontar para um arquivo de texto em branco?
-A configuração precisa ter um nome especial como "shaders.ini" ou pode ser nomeada livremente?

Estou perguntando tudo isso porque não consigo fazer nenhum sombreador funcionar, e a tecla HOME (que deve habilitá-los / desabilitá-los) não faz nada.



Atualmente estou testando o GSdx FX Suite v2.30: os arquivos "shader.fx" e "GSdx_FX_Settings.ini" estão na pasta "shaders", configurei o " GSdx_FX_Settings.ini" com um editor de texto, mas Não consigo ver nenhuma mudança na imagem.

Agradeço antecipadamente caso você decida me ajudar.




Isso é realmente frustrante! Tenho basicamente as mesmas dúvidas!

Quer dizer, eu conheço os caminhos das coisas, arquivos, pastas e tudo mais. Mas eu não consegui fazer funcionar ... nestas etapas:

Habilite o shader externo no GSdx usando um dos três métodos abaixo:

    Habilite a caixa de seleção Use FX Shader nas configurações do GSdx.
    Pressione Home durante o jogo.
    Adicione shaderfx = 1 linha a GSdx.ini.

fonte: https://wiki.pcsx2.net/External_shaders

Tentei duas dessas três etapas, não tentei a terceira porque não sei exatamente onde dentro do arquivo de edição devo escrever "shaderfx = 1" se no começo, no final, onde?

Outra dúvida, neste arquivo "GSdx_FX_Settings.ini" que é praticamente um editor SweetFX "Só irei trocar GSdx.fx ou qualquer outro arquivo com a extensão" .fx "?!?!?!

Consegui fazer tudo funcionar, tudo os jogos que eu queria a 100% .Mas essa maquiagem final não deu certo!


Aguardo uma dica, uma ajuda de algum membro do fórum que esteja mais familiarizado com tonalidades externas.

This is really frustrating! I have basically the same doubts!

I mean, I know the paths of things, files, folders and everything. But I couldn't get it to work ... on these steps:

Enable the external shader in GSdx using one of the three methods below:

    Enable the Use FX Shader checkbox in the GSdx settings.
    Press Home while in game.
    Add shaderfx = 1 line to GSdx.ini.

source: https://wiki.pcsx2.net/External_shaders

I tried two of these three steps, I didn't try the third one because I don't know exactly where inside the edit file I should write "shaderfx = 1" if at the beginning, at the end, where?

Another doubt, in this file "GSdx_FX_Settings.ini" that is practically a SweetFX editor "I will only change GSdx.fx or any other file with the extension" .fx "?!?!?!

I managed to make everything work, all the games I wanted at 100%. But this final makeup does not work!


I await a tip, a help from any member of the forum who is more familiar with external shaders.
CPU :AMD Ryzen 5 3600 6-Core Processor, 3600 Mhz
GPU :ADM Radeon RX 5700 XT
#7
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 3 Guest(s)