Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I'm getting runtime error whenever I open a game
#1
Hello. So yeah, if I open a game  on my laptop (Fruit fall in my case), I get these 2 errors:


[Image: 8TbI0h1.jpg]


At the moment I'm mostly interested in the runtime error rather than the sound one.

Some info about my laptop:
Processor Intel Core i5-8300H @ 2.3GHz (turbo frequency 4.0GHz)
Number of Cores 4
Video Card NVIDIA GeForce GTX 1050
Total Memory 8.0 GB
Operating System Microsoft Windows 10 Home
DirectX: 12



My settings:
[Image: ZxScGrL.jpg]
[Image: AskLEgF.jpg]

Emulog:

Code:
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 17763), 64-bit
Physical RAM     =  8052 MB
CPU name         =  Intel(R) Core(TM) i5-8300H CPU @ 2.30GHz
Vendor/Model     =  GenuineIntel (stepping 0A)
CPU speed        =  2.303 ghz (8 logical threads)
x86PType         =  Standard OEM
x86Flags         =  bfebfbff 7ffafbbf
x86EFlags        =  2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
Binding   GS: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\gsdx32-avx2.dll
Windows 10.0.17763
Binding  PAD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\lilypad.dll
Binding SPU2: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\spu2-x.dll
Binding CDVD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\cdvdGigaherz.dll
Binding  USB: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\USBnull.dll
Binding   FW: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\FWnull.dll
Binding DEV9: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9693 games on record (loaded in 153ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 10.0.17763
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Current Renderer: Direct3D11 (Hardware mode)
Opening CDVD
isoFile open ok: C:\Users\42073\Documents\Fruit Fall.bin
Image type  = CD
* CDVD Disk Open: CD, 1 tracks (1 to 1):
* * Track 1: Data (Mode 1) (25224 sectors)
Opening USB
Opening FW
Opening DEV9

For some reason on log from previous launch said "some kinda plugin falure" with padpokopom. It no longer says it so whatever.


There are several things to try which I mostly haven't tried yet (I also dont want to ***** my laptop up) such as:

1) install vc++ 2015 x86 (by jesalvein) - shouldn't I get x64 version instead?
2) remove AVX plugin (by flatout) - I actually tried this and it didn't work.
3) install DirectX End-User Runtimes (June 2010) (by topken, same thread)
4) update DirectX somehow -- could this help??
5) DirectX End-User Runtime Web Installer (by refraction) - I'm too tired, is this the same as 3)? On the website it says it's only up to DirectX 9.0c and not newer versions, my DirectX is 11, so what?


Which of these would you advise me to do? Or is there some other thing to try? Also do I need to reset my computer after I try any of these things?

Thanks a lot for your time.
Reply

Sponsored links

#2
DirectX 9 is a separate entity from DirectX 10/11/12. Microsoft has not shipped it alongside Windows since XP or Vista, and you need to install it manually. At this point it's a holdover for older hardware/operating system users, but yes, you will need to install DirectX 9 if you have not already. Seeing as it is an XAudio issue, and XAudio is part of DirectX, I would place my bet on this being the issue.

VC++ 2015 x86 is necessary, but seeing as the program at least launches, this doesn't seem to be missing on your system. PCSX2 is not a 64 bit app, so the x86-64 version is useless. Though, little known fact, Microsoft's VC++ 2017 contains everything from VC++ 2015, so you may be able to get away with it instead.

Side note, your PCSX2 version does seem old, we generally recommend using the dev builds these days, but I'd focus on getting your current version running as a start.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#3
Give this dxwebsetup a try to see if it fixes your XAudio issue Smile


Attached Files
.rar   dxwebsetup.rar (Size: 248,55 KB / Downloads: 19)
Reply
#4
Ohhhh.... so actually I tried the latest dev build and wouldn't you know it, it seems to work just fine. Tried it for both Fruit fall and Sims 2 Castaway.
Thanks guys, I'll let you know if I have trouble running any other games in the future.
Reply




Users browsing this thread: 1 Guest(s)