ICO: Windmill Area
First post.

I've been playing through ICO for the first time and have got stuck. I'm unable to pass the windmill section. I can't reach the ledge above the door of the windmill. I didn't want to check a walkthrough but I'd tried everything.

So I checked a walkthrough and it said to do what I had already been trying. I watched a video and realised that the steps in front of the windmill don't reach as high in game as they do in the video. So I can't reach the ledge for good reason. I did a search but only found this mentioned in one other place and that post only got two replies non of which helped.

Here is a shot from the emulator:

And here it is in the Let's play video:

Is this a known issue, perhaps something has loaded oddly? I tried leaving and entering the area again. I also reloaded from a previous save and when I got back there it was the same as the first time.


Oh and I hope this is the right section. At a cursory glance I saw other game specific questions here and no other section for it.

Sponsored links

And I'd tried jumping on the broken block to get up there already. I tried again and had to try a fair few times before he'd grab the edge but it worked.

I wonder why the NTSC version has slightly different puzzles than the PAL.

Thanks for your help.

Users browsing this thread: 1 Guest(s)