Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ICO running at 60fps, but in slow motion
#1
I've been having some problems trying to get ICO to run at 60 fps (PAL version). By default, it runs at 60fps when I set it to NTSC mode, but it is extremely jittery and runs slowly, despite PCSX2 saying that it is at 100% speed. After applying the cheat patch I found in this video (https://www.youtube.com/watch?v=-F0MGUSQfuI) and turning on Single Framestep in the debug menu, the game now runs smoothly but still runs slowly at around half speed. I can *sort of* fix it by running it on Turbo Mode, but that makes certain animations play out too fast and makes the cutscenes go too fast.

Here's a video I recorded of my issue: https://www.youtube.com/watch?v=gtTVox8nZwg
0:00 - 0:14 is what it looks like by default. 0:14-0:35 is what it looks like with the Single Framestep enabled. 0:35 - 0:56 is what it looks like in Turbo Mode.

Here's my settings:

[Image: 1.PNG]
[Image: 2.PNG]
[Image: 3.PNG]
[Image: 4.PNG]
[Image: 5.PNG]
[Image: 6.PNG]

[Image: 7.PNG]
[Image: 8.PNG]

I have an i5 10600k and a GTX 2070 Super with 16 GB of RAM. No other game have this issue (SoTC, Rule of Rose, Silent Hill 4 and MGS 3 work just fine). I have already tried every combination of EE Cyclerate, EE Cycle Skipping and MTVU On/Off, and they don't seem to help. Hope this is enough information!
Reply

Sponsored links

#2
I may be wrong,but i think ico had that kind of problem on real hardware. Can you try on your PS2 ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(07-28-2020, 07:30 PM)jesalvein Wrote: I may be wrong,but i think ico had that kind of problem on real hardware. Can you try on your PS2 ?

I don't have the PS2 anymore unfortunately, I left at home while moving to college and I've just been using the emulator. I do remember it running quite a bit smoother than this, but I've seen entries in the wiki stating they were able to get it running at 60 fps.
Reply
#4
Hm. We actually don't run the wiki. Could you please try the pcsx2 versions stated in those wiki entries ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
Well, this had a strange result! The game plays like I have Turbo Mode on, essentially, even though its turned off. The gameplay is fine, but cutscenes play out way too fast.
Reply




Users browsing this thread: 1 Guest(s)