Ico Crashing or Something else?
SO I'm using PCSX2 for the third time, the previous two attempts resulted in a few problems, however grabbing the latest beta 0.9.7 works this time with a few niggles.

I'm trying to run Ico, and I noticed it had some weird graphical glitch throughout the intro, it was showing them travelling along a forest-like path, and then it went sort of washed out yellow, you could just about make out the character outlines.

Anyway I get to a point where the game has either crashed, or it's no longer recognising the game inputs from the pad. I'm using a ps2 pad via a usb dongle thing.

Here's a pic

[Image: icoem.th.gif]

My PCSX2 config is as follows:

[Image: config.th.gif]

My pc:

core2quad q8200 2.3GHz
4gb ram
Nvidia 9800GT
OS: Windows 7 Ultimate

Also I'm using dx10/11 to display the graphics. Sometimes it shows up correctly like I said, or like also said, it goes wahsed out yellow, but I can live with that to some extent but not if the pad doesn't work. I noticed tha when i got to that point in the screenshot the games was making a weird electrical sound or something, which I believe is part of the game.

Thanks in advance in any help you can provide to get this working properly.


Sponsored links

ah.. so it isn't just me... try the old beta if you have it (1888) it was supposdely working then (I didn't check then, I just reciently bought it) I'll have to try on the revision myself as well.
I don't have an earlier version, the only ones I have are the stable releases that didn't work for me and my system, this is the first build I've managed to get working first time with little to no effort.

Were you having the same graphics problem, or the pad input problem?
the game locked up before even the menu for me. I'll pm a link to an older revision, since it will be unofficial and not looked at too nicely.
Ok well I just tried Shadow of the Colossus too, and at the menu it won't let me go to the options, but I can select a new game to play. The game only runs at 12-17 fps on my system, so I guess a quad core isn't enough for the game at the moment. It was pretty demanding and running at a poor frame rate even on the original hardware.

I tried ico with the directx 9 setting but resulted in the same graphical issue. Will try an earlier build as suggested - this control thing is puzzling me though, since I can't select anything but start new game on both titles. In Ico I couldn't even choose 60hz over 50hz.

I can play shadow of the Colossus at decient speeds.. what GPU are you using?
I've got an Nvidia 9800gt I guess it's kinda old and I should upgrade right?
nah with that gpu you can play every game at native ps2 resolution and some at x2 or even x3 (totally depending on the game)

your cpu is the limit factor here, you should OC to 2,8 at least on stock volts.
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
um.. I'm using a 8600...

try this:

enable speedhacks: use IOPx2 and EE 1.5 (setting #2) see what kind of speed that gives you with SotC

@iakoboss7: my Dual core is a 2.2, and I'm getting better speeds? not to mention my GPU is older... That doesn't add up
ah native res - I've been trying to run it on non-native res, actually 800x600 with no special effects/aa or anything. So that's why it runs so slow otherwise? Is it just a case of trial and error with regards to upscaling?


Users browsing this thread: 1 Guest(s)